Blender rig exporter/animation importer


#21

You should be able to just go to Studio > Play Solo > Copy your character from the workspace


#22

@Den_S

I don’t think it matters if you disable animate or not. Just make sure the character model is archivable then copy it and paste.

I believe this is because we do not save the “secret” property of Motor6D which is the actual animation property.

tl;dr animations shouldn’t matter


#23

Would that turn me into a t-pose/basic pose? i currently have a ninja animation pack.

edit: thanks alex!


#24

Ah, you’re right, that’s cool.

Still make sure to Anchor the HumanoidRootPart though!


#25

When I import the rigs into Maya this is what my hierarchy looks like:

But when importing it in an renaming it to “__Rig2” this ends up happening:


I tried renaming “RigArm.001” back to “RigArm” but it just flip flops the names.


#26

The naming you’ve currently done + the hierarchy seems correct. The important thing is that the armature object is named __Rig and __Rig2. Those are the ones with the orange icon. Inside such an armature object there’s also the armature data, which is the one you now try to rename. That name doesn’t matter as the data is not referenced by name.
The children of the data object should match names though (but that’s already the case). The extra _end bones shouldn’t matter either.

Also make sure to set the keying set to LocRot, forgot to demo that in that video.


#27

I can’t get this working D:

After importing a Mixamo rig, renaming it to __Rig2 and setting the keying set to LocRot on both rigs, running the code just selects Rig2 and does nothing else even when all bones are selected in __Rig.

I saved the rig to fbx and uploaded it to Mixamo, got some animations, downloaded and imported.


#28

WHat about LocRot? I have no idea how to use blender lol


#29

Any error in Window -> Toggle system console? Sounds like the rig hierarchy doesn’t match.

That value at the bottom in the timeline (no need to insert keyframes, the script does that automatically, only need to set a proper keying set such as LocRot):
https://devforum.roblox.com/uploads/default/original/3X/7/4/74d43ead230339ac1413199aea027e1e529cfb85.png


#30

I have updated both the Roblox plugin and the Blender addon;

  • Support for named keyframes (sort of hacky support, but I needed it myself)
  • Easy import of animation data from rigs inside of FBX files

Importing animation data from keyframes stored in a FBX file to Roblox is now much simpler, see the video below:

Animation length is also automatically derived from the imported animation data. Just remember to set a suitable keying set before importing anything (once), choose LocRot if unsure.

(edit: updated again to fix an issue)


#31

For anyone who would like to use (somewhat accurate) motion capture on a budget, I suggest you check out this video which explains how a Kinect (Kinect 2.0 suggested, which you can buy on ebay for like $50 USD) can be used as a motion capture device using a certain adapter for PC (which is like $35 but also makes it work with the Xbox One S). This is a much more affordable mocap setup and can work directly with blender. The guys in this video don’t go through the setup or use blender, but they show that it is something that can be quite useful and accurate.


#32

There actually is a Blender add-on that lets you mocap directly in the program using a Kinect. Though it’s a bit outdated, so i don’t know if the 2.0 works with it.


#33

The videos not working. No video with supported and MIME type found.


#34

Well, no clue why that happens (works fine for me). I guess you can just try updating the Blender addon, then simply setting the keying set and using the new button. Should work instantly.


#35

Might wanna try uploading to Youtube. It works when I import it now! Althought when I paste the code in Studio it doesnt work


#36

Are you using the “big animation” button? Otherwise, it may help me to get the files you’re trying it out with.

(Also, is the other video I’ve put here also broken?)


#37

Oops, I just pasted the code in without the big animation button- should I just use that from now on? And no, only the last video is borked.


#38

Well, if the “big animation” one works, then yes :stuck_out_tongue: .

Weird that one of the two videos work, though. :expressionless:


#39

Can you make it so that it doesn’t have to publish the animation? or did I miss one of the features?


#40

It should autoplay the animation when you load the animation on the rig you’ve exported. The game simulation should run though, otherwise it can’t actually run it (but the plugin auto-enables the simulation when you start it).