Blender rig exporter/animation importer


#84

It doesn’t give me an option to save as python. It says “.txt” or “all files”


#85

You would have to change the file extension from the file explorer, toggle the “File name extensions” option by going to the view tab, you should be able to edit the file extension from there.(Just realized, you could also select “All Files” and put “rbxblender.py” which would also save the file as a python file.)


#86

I’ll try it soon.


#87

Based on your screenshot it looks like you have “common file extensions” hidden. The file is showing up as rbxblender.py instead of rbxblender.py.txt. This is an annoying Windows default that doesn’t contribute anything but confusion in cases like these. To enable all extensions, open View and enable “File name extensions”

After doing so, you’ll be able to see the .txt part and remove it. Enabling hidden items might be useful in the future as well – it doesn’t really change much since hidden files are for the most part under the user/Windows directories, but it will prevent a similar situation from happening where “Why can’t I find this folder?” because it’s hidden.

@Den_S Might want to note this in the OP


#88

Thank you both very much, I never knew about this. Really happy that I will be able to do this now.


#89

It should work just fine with R6.

Will add that, thanks.


#90

Apparently I am no longer allowed to edit the OP :stuck_out_tongue: .


#91

this is what happens.


#92

I only get a head node for the rig when I export an R6


#93

Can you send the blend file you use + the anim you try to import?

I do notice a weird issue where the face is seen as a separate object rather than it being mapped as a texture. There seems to be another weird issue where some transformations aren’t properly mapped, will need to check that later. Removing the face in Roblox helps a bit, at least.


#94

I’m getting this error everytime I try to ‘Import model’


#95

This is the full error


#96

Do you have the .obj import addon enabled? (I think it is enabled by default, but that error seems to suggest otherwise…)


#97

It gives me that error too, but the model still imports without a problem. Check the entire visual workspace in blender to make sure that it is actually there. If you export the rig in studio when it isn’t at the position of (0,0,0) It wont be at the center of workspace in Blender. Have the OBJ import/export addon enabled and double check every direction of Blender workspace. :slight_smile:


#98

Yeah.

[EDIT]

All of the issues above were managed to be fixed by enabling a few other options under the community tab.


#99

This is very impressive!
Unfortunatly Im a complete noob at animating in blender, but this is still amazing!

Well done!
:star: :star: :star: :star: :star:


#100

Hi!

You can use animations from mixamo :slight_smile:

If you need help let me know!


#101

has OP fixed it so it exports R6 rigs properly


#102

Currently I’m prioritizing some other things I have to do, but I’ll get back to fixing this sometime. Most rigs don’t have joints whose rotation points have a non-identity rotation matrix, but R6 does, which causes issues with some transformations…


#103

Maya: http://i.imgur.com/E0wir9k.gifv

Using the import FBX option: http://i.imgur.com/4ESAfsZ.gifv

Any idea what went wrong?