How to enable Dark Theme in Studio


#1

This is my original tweet: https://twitter.com/Spooksletsky/status/1009524376625008640

Instructions here as well: https://twitter.com/Spooksletsky/status/1009524750849200128

DARK MODE IS ENABLED ALREADY, JUST FOLLOW STEP 5 IF YOU DON’T KNOW HOW TO ENABLE

Easier method: Steps to perma enable(Far easier and less steps):

  1. Go to %localappdata%\Roblox\Versions and go to the version folder containing Studio files. (Look through the folders until you find RobloxStudioBeta.exe in one of them if you have no idea. Name of the folder changes every week I believe)
  2. Create a folder called ClientSettings
  3. Create a file named ClientAppSettings.json
  4. Paste this into the file, then save and relaunch studio:
{"FFlagStudioThemeSwitchingEnabled":"True","DFFlagStudioThemeSwitchingEnabled":"True","SFFlagStudioThemeSwitchingEnabled":"True"}
  1. The final step is to go into Studio settings and enable Dark Theme by going into the general section of Studio Settings and changing the UI Theme.

Longer method: Steps to perma enable (Different and easier steps):

  1. Go and download @CloneTrooper1019’s Studio Mod Manager: https://github.com/CloneTrooper1019/Roblox-Studio-Mod-Manager
  2. Launch the Studio Mod Manager, it should look like this:
    image
  3. Press “Edit FVariables”, if a prompt appears saying “Beware Dragons” or something like that just accept and continue. Wait for the editor to gather the FVariables.
  4. A window like this should popup:
    image
  5. Simply search for “StudioTheme” and it’ll appear like this:
    image
  6. Select it like I did in that image then press add, accept the prompt and it’s added to the manager’s version of Studio. It should look like this:
    image
  7. Exit the FVariable Editor and press “Launch Roblox Studio”.
  8. The final step is to go into Studio settings and enable Dark Theme by going into the general section of Studio Settings and changing the UI Theme.
    THIS WILL NOT WORK WITH REGULAR STUDIO ONLY THE MOD MANAGERS’S VERSION

PS: There is a method to do it without the editor, however when studio restarts the config also is reset so that does no good.


Add a dark theme for studio
See What's Coming in 2018: This Year's Developer Roadmap
#2

Be aware that changing environment variables, like fast flags, is not supported by Roblox and may lead to instability. It should be fine in this case, but there may be some functionality that isn’t working.


#3

image


#4

If you guys find any issues or run into any crashes, feel free to let us know.


#5

Updated the post with detailed instructions on how to enable.


#6

No issues so far, however, I would like to have the option for Dark Theme not to reset my studio script editor theme. Although I do really like it. So far it’s fantastic!


#7

Yeah I noticed that. As far as I know we save the script editor colors per UI Theme, so if you switch back to light you can restore the values.


#9

Alright that’s really good to know


#10

Can you provide a screenshot? What icons are you talking about?
I think the studio team had to switch to a newer version of ribbon to support the dark theme effectively, but I don’t know the specifics.


#11

I just double checked and I found that both are the normal size. My guess is that since the icons don’t fully support dark mode yet, they just seem smaller. :confused:


#12

image

yeah it’s just an illusion. That actually really bothered me and I’m still gonna stick with light theme because it seems slightly larger.


#13

Not for sure if this is normal but it looks like the UI Editor icon is a tad messed up image


#14

Yep, known. Will be resolved next week


Studio Dark Mode Issues
#15

Updated with a method that works with default studio and doesn’t need the mod manager


#16

Came here to say this.

Any time you’re forcing features on like this, keep in mind that there are reasons they’re not enabled. If they don’t work right or do something wild like trash your AppData, you can’t really complain. :wink:


#17

Good thing I included a detailed guide!


#18

Thanks for this tutorial. Really helped me while testing an update to my Editor Themes plugin! It now switches UI theme based on the script editor theme chosen. If anyone wants to try it out (and has enabled the flag), you can grab it here: https://www.roblox.com/library/1858434956/Editor-Themes

It’s pretty satisfying to see it all change together. If you haven’t enabled the flag for UI Theme then it just acts as usual, affecting only the script editor colours.

Here’s a quick video of it in action for those who don’t want to mess around with their Studio variables: https://youtu.be/mJf7rcjVlj4


#19

Oh wow, I didn’t know about this plugin! Definitely installing right now.


#20

Mines just set to VS :confused:


#21

sweet, thanks gamer