How to enable Dark Theme in Studio


#42

Seems that icon was ripped out of an image with a white background. It looks like it should be an easy fix though, as we have the same icon without the white background already packed into the executable:

Fixed icon:
474


#43

Will the top bar on Lua Widgets also be black?


#44

Do app developers actually have the ability to do that? Isn’t it controlled by your Windows theme settings?


#45

I think that’s a Windows thing, not sure if they can do anything about it


#46

@BanTech yes they do. My Google Chrome topbar is black. image

Also this:


#47

Google Chrome uses its own window rendering engine. Studio uses the environment’s. Hence why Roblox Studio looks like a normal Windows/Mac program depending on the platform you’re on, at least so far as the title bar goes. So I’m not sure if Roblox is going to work on that.

That said, I believe @DreamingMind was referring to having Lua Widgets automatically adapt to the dark mode, not referring to the window title bar.

If you’re using dark theme Studio, you can probably also change your Windows color settings.


#48

Pretty sure that’s not the case. Roblox can’t just automatically change the colors in your UI. It might mess up a lot of stuff. He specifically referred to the bar too, so I’m 100% sure that’s what he was talking about.


#49

But Roblox can automatically, and easily, change the background of widgets. Right now the dock widget’s keep their white background. I had to add a frame with size (1, 0, 1, 0) to my plugin guis to give that background properly. You’re right that the rest of the UI won’t look right, but Roblox can at least make it so that that background updates with the theme.

In order for Roblox to change what the title bar looks like for windows, they have to override Windows/MacOS and that’s probably not something they’re super interested in. I could be wrong, but I don’t believe that’s what the engineer was referring to.


#50

That doesn’t make sense. Look at the context again.


#51

That’s not the full context. This is the full context:

To which DreamingMind sent that reply.

Roblox uses Qt as their rendering library. We know this because there are Qt DLLs with the executable. And here is a post from the Qt forums about this very idea: https://forum.qt.io/post/430984

As you’ll notice, changing the title bar color is not an easy feat with Qt, as the very second post is from a “Qt Champion” saying you cannot do it from Qt. The second post does share a link, but the top answer on the link is a person essentially saying “yes you can, but you really shouldn’t.”

Hence why I do not think Roblox will be doing anything to the title bar of the windows.


#52

I love it! I enjoy dark theme on most things, so i’m really happy that i can finally have it on studio !


#53

I got this error and it wont let me click away :frowning: https://gyazo.com/fdd9077fff829aca6f7b4d7e486a3711.gif


#54

That looks unrelated to the dark theme. “Timed out” usually means that you’re having internet problems. Either Roblox Studio or Roblox Studio Mod Manager took too long to make a request and “timed out” because it took too much time. Make sure that your internet is connected properly.

You can close the program in the Task Manager. You can open the Task Manager…

Then you can Right click -> End Task on either Roblox Studio, Roblox Studio Mod Manager, or both. If that doesn’t work, then you can force it to close by using “End Task” from “Details” instead of “Processes”.

It’s not clear whether this caused by Roblox Studio or if it it’s caused by Roblox Studio Mod Manager. If the Mod Manager is not working for you then you can try the ClientSettings folder method, which is simpler. If neither method works, then it probably has nothing to do with the dark theme and has everything to do with your internet connection or Roblox install.


#55

It’s a Studio Mod Manager error for when it can’t pull the fast flags from the executable – unrelated to internet. @KFCPhoeyu Try closing all instances of Studio and re-opening mod manager, and then re-running the scan.


#56

is this correct



#57

I don’t think so. Windows likes to hide file names to make things “easier”. That file is likely called ClientAppSettings.json.txt . It should be called ClientAppSettings.json .

You can turn on viewing file extensions in the View tab:

Once that’s done, you’ll need to rename the file from ClientAppSettings.json.txt to ClientAppSettings.json. Windows will complain:
image

Press “Yes”.

Once your file is actually named ClientAppSettings.json, you should be good to go. You can turn off file name extensions if you want, or leave them on if you don’t mind seeing the more technical side of things.


You’ll have to turn on the theme in Studio’s settings, which are under File -> Settings:
image

It should show up in the Studio settings under General:
image

If it does not show up then make sure you named everything correctly and that your ClientAppSettings.json file has the correct text in it, then restart Roblox.


#58

thanks it works i didnt know i had to toggle file name extension


#59

I don’t know man, something about this theme just feels off, maybe it’s just the choice of colour? I’m not too sure.


#60

It might be since no ones really used to studio having a dark theme, the unknown always seems a bit off.


#61

I just compared it to some other programs that have dark themes and the Roblox theme just looks super flat and undefined in comparison, here’s an example:

Roblox vs a program I use for music production

It’s great that Roblox finally added one, but I hope we will be able to make our own themes :grin: