Is it possible to fix this ~ Unions

unions

#1

Hi , sometimes I come across this while working with unions
image
I make the door using Negate + Union and it acts as if there is an invisible brick blocking my way inside ( Shown in the image )

If anyone has a solution to this or a different way to work around this problem please let me know
Thank you
~Rismy


#2

Union collisions aren’t precise, and are “simplified” to use less data. The doorway is being left out of the collision check because, in the grand scale of the union, it isn’t seen as significant enough to affect interactions. I’d suggest cutting the union in half or in quarters, to allow for more detail with the collision.


#3

You can check your unions’ physics collision models by toggling this on in your studio settings

Make sure to turn it off though. It’s definitely not the kind of setting you want on appearance wise.


#4

How tall is the Union that you have there?

Basically negating is taking a percentage out of the solid Part or Union that is there. If you take a large section from a small Part then it will likely be visually and physically the same size.

If you have a large Part like a thick wall or round turret, and you remove a tiny doorway through it, it isn’t likely to be physically the same size as the hole that is created visually. You can make it better by cutting the large cylinder into smaller sections (so the percentage is better), or by creating a larger hole and filling it with door frame Parts.

Another way is to make the Union CanCollide off and put transparent walls where the Union is.


#5


Ask if you have any questions.


#6

If you’re in a rush. Set the union’s can-collide property to false, and then create invisible parts inside/around the union which acts as a external physical barrier for the union. Apart from the door of course.


#7

i do this one a lot


#8

I come across this and what I use to do is separate it and re union it and if that still wont work try making it a bit bigger or smaller and I can see another color is that a part or another cylinder with in it because make sure you try to see if thats the prob as well


#9

I have had the same problem before what I did was click on the union and change the collision type to default and then there’s a property below that change it to 0 this seemed to help me most of the times I hope it helps you too.


#10

Check the Decomposition Geometry in Physics settings


#11

I wouldn’t suggest that you use unioning to create a door at all. It’s been an ongoing issue, and I noticed it when unions first came out. I tried making a cave exploration game (it was a sad attempt at a game.) and I made the entire cave system out of unions/negates. The hitboxes are not accurate, and Unions are also not the most efficient method. They often use more triangles than needed. But, meshes, in this case, also do not work 100% of the time, either. Personally, for this, I’d suggest you make the doorway out of blocks. Although, some people are saying things about hitboxes and their settings (I haven’t done much with the hitbox settings), so I would recommend that you try their method before you delete everything and start from scratch.


#12

As I’ve mentioned above, Roblox uses Approximate Convex Decomposition, so concave shapes at door frames, caves etc. will have inaccurate collisions, especially if the the union is additionally complex.

And also, building such simple shapes shouldn’t be done by unions. It’s never good to union things just for the sake of unioning it. They’re much less efficient than just a few, normal parts.


#13

Yeah, if you can do it with a few bricks or a mesh, you might not want to union it.


#14

In this case I would probably try to not use a union, or try adjusting it a little and see what happens.