Metal Graphics mode on Mac cause drops in FPS to rendering many parts


#1

[Edit] With today’s update, playing on Mac is practically impossible without getting 10-30 FPS on most part intensive games. New repro place: https://www.roblox.com/games/1995098790/Baumzs-Place-Number-122

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur. With the graphics mode set to Metal, I get large drops in FPS when ever there is like 20 or more meshparts visible in the frame. With the graphics mode set to OpenGL the drops in FPS does not occur. This is a problem as when ever I play games using the Roblox client, it defaults to using Metal as the graphics mode.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior. Happens everytime.
    Repro Place: https://www.roblox.com/games/1995098790/Baumzs-Place-Number-122
    Steps to repro: Join the game and get a few of the palm trees in the viewport (the palm trees are all the exact same meshpart). Notice there is a drop in FPS.

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue. Happens on live games and in studio.

  • Would a screenshot or video help describe it to someone? If so, post one.

Metal

OpenGL

  • For graphics bugs, it is sometimes helpful to know your system specs, especially graphics card.

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke. Started like a month ago, got worst like 2 weeks ago.

  • Anything else that you would want to know about the bug if it were your job to find and fix it. Here is a gif of the issue occurring on all graphic levels. Also one of an actual real game


As a bonus question, is there anyway to force the Roblox client to use OpenGL until this issue can be resolved?


#2

Does Roblox not respect the OpenGL setting in Settings > Rendering > GraphicsMode on Mac in Studio?


#3

This setting only applies to Roblox Studio and doesn’t apply to the Live Roblox client

Source:


#4

Can I get confirmation that this bug is being looked into? And possibly having the default graphics mode for Macs switched to OpenGL? Also is it not possible for me to manually switch the graphics mode to OpenGL for the Roblox Client?


#5

With today’s update, with draw distance being greatly increased for lower graphics levels, I can’t even play my game on level 1 graphics without getting 10 FPS on my Mac. Mostly because it’s using Metal instead of OpenGL.

Even with OpenGL I’m getting 30-40 FPS

Place of issues: https://www.roblox.com/games/1995098790/Baumzs-Place-Number-122

Metal:

OpenGL:


#6

We disabled this update after a bit of a monitoring period; thanks for the report!


#7

For your original problem, please attach a profiler dump so that it’s easier for us to investigate. Also, is there a different repro level? Can’t see palm trees on the one that’s linked.

And no, you can’t force the player to use OpenGL.


#8

FWIW looking at this closely, we think we found a performance regression on Metal from a few months back that would affect this. We’ll try to ship a fix for this in a week.


#9

Will do when I get home, out for another hour or so.

The issue is more prevalent in the current repro place, and actually isn’t effected by just meshparts, as the ballpark doesn’t have any meshparts in it.


#10

Here is the micro profiler dump for the place with the palm trees.

In Studio with Metal:
microprofile-20180703-003129.html (1001.2 KB)

In Live Server with Metal:
microprofile-20180703-003442.html (877.6 KB)

I went ahead and reverted the place in the OP back to the place with palm trees, as I am having trouble creating a new game atm.


#11

Thanks! It looks like this problem is exclusive to NVidia GPUs. We have an in-house repro. The fix for the significant perf degradation for all parts has been enabled yesterday, and we should ship a fix for the mesh part slowdown in a week or so.


Constant 30-40FPS in Studio
#12

I don’t think the issue is exclusive to NVidia GPUs. I’ve been experiencing this same lag both in live game and studio on my mac. The description and timeline given by Baumz pretty much matches what has been happening for me, and I have an Intel HD Graphics Card.

20%20PM


#13

The fix for this should be live right now, performance of MeshParts should be back to normal.