Super laggy script editor


#22

Fair but this has been an issue for close to 7 months, with easy repo.
So yes, I am a bit impatient. Apologizes. It’s just been slowing me down.


#23

This has been one of the more annoying studio issues I’ve had the past couple months. Sometimes I have to resort to switching to my Windows partition to edit longer scripts. Hope it’s resolved soon!


#24

We are still looking into this issue, but it is taking some time. Please bear with us in the mean time!


#25

Any updates??? I can’t even script efficiently at this point.


#26

I’m struggling too. My laptop has been in for repair, and my iMac 5K has HORRIBLE delay to the point where I’m using an external editor. I appreciate you’re still working on it and thank you for that, and any updates would be super encouraging.


#27

We’re still looking into this issue. We haven’t been able to identify any single item that causes this issue, so the process of fixing it is taking some time.


#28

If it was your team who recently made the Mac pointer not deselect as often, and made it a lot easier to get it to reselect, THANKS!!!


#29

Do you have any updates? Sorry to be impatient :confused:


#30

I get the same thing. This is super annoying. Sometimes it can take up to 5 seconds to get one to two words onto the screen. This slows down the development process a ton. I’ve uninstalled studio and reinstalled, restarted my computer, and opened studio in different ways (on the site and the application button).

My Mac is about a year old (2016 model). I’ve had this bug for up to at least 5 months. It’s really annoying. Hope it gets fixed soon.

I’ve found a temporary solution though.

When I get like really annoyed by it or I’m making a longer script, most of the time I resize the studio window to about half the size and the lagging stops. But it’d be nice if the lag wasn’t there at all in the first place.


#31

Thank you so much!!


#32

oh dude u’re actually the best thank you so much


#33

No problem. :slight_smile:


#34

This is actually super useful, thank you. Makes it a bit more bearable


#35

What is that status on this? This is a huge bug and seems to be ignored.


#36

No problem. :slight_smile:

I agree.


#37

This is not being ignored. We are actively looking into it.

Studio team is very aware of this issue. We will do our best to fix this bug.


#38

Try this:

  1. Go to System Preferences->Displays->Color (for the Built-In Retina Display)
  2. Change Display Profile to Generic RGB Profile
  3. Restart you computer

High Sierra Issues Makes Studio Unusable
#39

Is there a solution that doesn’t involve changing the color profile of my whole display? Props for figuring that out, I just like my system the way it is and would prefer to see a solution that works by default without having to change settings for my entire display.


Text delayed when typed into script (macOS Sierra)
#40

Unparent the script editor from studio.


#41

This doesn’t fix the problem for me