Team Create Bugs. Post 'em Here!

studio
teamcreate

#63

There’s another one for you.


#64

Hey everyone,
Thanks for your continued reporting on Team Create issues. Our most recently released Studio version now includes the addition of a Broken Assets tab in Game Explorer, which will be populated with any linked assets that are broken or corrupted, enabling you to delete said assets. In addition, any broken non-asset resources will have a different icon, and be located in its related category. This change was made in order to reduce the amount of Game Explorer load failures, resulting in a better user experience overall.
In addition, there have been fixes made to a number of Team Create crashes in this latest release.
Thanks again for your help. Fixing Team Create issues is still a high priority for us, and I will keep this thread updated on new Team Create fixes.


#66

Team create doesn’t publish properly sometimes and even publishes a wrong version.

For example, I do some script edits, publish it a few times because I forgot to add something, wait for the “blablabla Published successfully!” then I shut down the servers to apply the update.

I join the game and people are freaking out about how something is fatally broken because TC published the wrong version. Even when I add an extra print(“Test”) to see if it’s actually updating, then publish it and wait for the message once again, it doesn’t apply correctly. when this happens I have to turn off team create and for whatever reason, it wipes all of the progress I made.


#67

Thanks for your report. We have received similar reports of issues like this and consider it a high priority issue to solve. We will be working on a fix as soon as we can.


#68

Over the past day, me and a few others have been experiencing a “Server Save Failure” while working on team create. Unfortunately, the first time, we didn’t notice the error and this caused us to lose nearly 4 hours of work (from 3 different people).
I am not yet sure if this is reproducable, or the cause.

Here is a log from one of the other people working with me (don’t mind all the Door logs, he was testing something).
https://pastebin.com/iBfQ0UB8
The game link is:

  • I am not entirely sure if it’s related to the above report or not, but just though i’d put this out there,

UPDATE: It is the next day and this issue persists. This is becoming a problem as we have to save local copies every time we make a change (even manually publishing fails).


#69

Have you tried disabling and re-enabling team create? Just a thought.


#70

Thanks for the report and logs. We will take a closer look at what is happening on the server side and get back to you.


#71

This has been responded to by a Roblox staff already, but I thought I’d post it here for further investigation. This could be occurring in just Team Create or all places, all I know is that it happened in a particular game for me.


#73

Huh, I have already posted a topic when noticed that.


#74

#75

My output is being spammed with the following message in certain Team Create places (not all of them).

20:11:47.325 - (ignored) readFast past end (Packet size: 10129, packet type: 27)
20:11:47.326 - 
20:11:47.428 - (ignored) readFast past end (Packet size: 10129, packet type: 27)
20:11:47.429 - 
20:11:47.573 - (ignored) readFast past end (Packet size: 10129, packet type: 27)
20:11:47.574 - 
...

The message is being sent multiple times per second. It appears to only be a minority of places, as I can’t reproduce it in any place other than the specific one where I first noticed it. Despite that, it always happens in that place, even after a restart.


#76

Experiencing the same issue here


#77

Thanks for pointing this issue out, this seems to be a fairly new issue. Could you PM me the place ID with this issue so that I can file a bug and take a closer look please?


#78

Hey there. Not sure if you fixed the bug or if me continuing to edit the place caused the bug to stop happening, but either way, it’s gone now. So if you haven’t investigated the bug in the place ID that I sent you yet, you may need to get another place ID from someone else. cc @AbstractAlex @VitalWinter @PeteyK473


#79

Yes we have a DM with my broken place id :slight_smile:

Unfortunately mine still seems broken as of right now

image


Getting error spam in Output: (ignored) readFast past end
#80

When I or my development partner try to access one of our games which is using team create, roblox studio simply crashes, other TC games work fine but since this most recent studio update it has been doing this. Neither of us have been able to get onto it at all. image


ROBLOXCRITICAL Studio crashes when connecting to team create places
#81

#82

Thanks


#83

@Nightgaladeld / @DreamingMind

Can we lock this thread? Bugs are meant to be posted in bug reports so all replies are on-topic pertaining to the bug.

This doesn’t allow for any bug tracking as well.


#84

(this is a really old thread so I apologize if it’s not where this belongs, although it is regarding team create)
I recently came across a bug in my friend’s team create; when he adds a new player to the studio file they’re not visible in the team create menu unless I rejoin the game.

If he were to add BuilderMan to the team create, I would be unable to view it without exiting and rejoining the file.

Sorry @AbstractAlex I didn’t see your post until after I put this in