Union parts don't always appear

bug

#1

Okay, so in my game I have doors which are union parts:
image

Most the times they load correctly, however every so often they do not load on the client.

Here’s how it should look:

Here’s what it looks like when the unions don’t load:

The part is still ‘physically’ there - it just appears invisible to the client.

I’m not sure how to replicate this bug, it just happens randomly.

Why does this happen and is there any way to fix this without seperating the union?


#2

You should just try to use MeshParts imo, if you can’t I don’t really know what to say since I don’t mess with unions much, only importing and converting to Meshes


#3

Converting it to a mesh is honestly your best bet as @LordHammy said.


#4

I don’t really want to do this as I have over 100 doors I’d have to convert. Also, it would require me to alter my door teleportation system, which I ideally want to avoid.


#5

Only viable fix I know of is to Un-Union the door and then Re-Union it.

I’d also recommend avoiding using Unions in the future.


#6

Does it say anything in the output?


#7

I haven’t looked, but Ill try and get a screen shot next time it happens


#8

I have had this same issue but not to me directly, but a few players experienced it. What I did to help some of them was preload the asset with ContentProvider, but it still ended up happening occasionally. I think this is due to slow loading with their device/internet connection. Usually they can fix it by rejoining the game until it works, because if they don’t, sometimes the object will be invisible and not load no matter how long they wait. Makes me wonder if its something more than just their device/internet messing up the loading of the part. Either way, it seems to only happen for unions so like others have said, converting it to another basepart would be a good idea.


#9

You can preload unions?


#10

Ok thanks


#11

Anything that needs loading can be preloaded. Includes Parts, MeshParts, Unions and other things.


#12

If it’s an issue of just getting the data and loading the part in would MeshParts make a difference? I’m pretty sure it still has to do the same thing