Weld Button doesn't work on non-cancollide parts


#1

Using the “Constraints - Create Weld” tool does not work if one of the parts has CanCollide set to false. Considering it is perfectly OK for non-collidable parts to be welded, I would consider this to be either a bug or just an undesired behavior.


Current behavior: The Create Weld button does not work for any parts that are not collidable.

Repro:

  1. Create 2 or more parts in Studio
  2. Make at least 1 of them non-collidable
  3. Select the parts
  4. Use the Create Weld button on the toolbar (Model tab > Constraints > Create > Weld)
  5. Parts will not weld together

Desired behavior: Parts weld together even if any of them are not collidable.


I spent a lot of time thinking the button was broken before figuring this out. I’m sure it has confused many other people too.


#2

It appears there may be other cases in which the button doesn’t work, but I have not figured out how to reproduce it.


#3

For my Incubator project almost the whole world aside from buildings and terrain were physically interactable (in other words: unanchored). To keep the models together, I extensively used the Create > Weld tool, and every time I would have to enable collisions for the whole model, use the tool, and then revert collisions to what they were previously.

Examples:

The water in this bucket has collisions disabled:

Anything that’s not blue on this cart has collisions disabled:

Ropes on this elevator have collisions disabled:

There’s only one collider (pink part) for this swinging platform:

This flag has tiny cylinders between segments to smooth joins – they don’t have collisions enabled:



If you have the RibbonBar minimized, clicking the “Weld” button will not work. You need to select it from the dropdown every time. This is a separate issue, and already logged internally.


#4

Yeah we’ll call this a bug. We’re tracking this internally now and we’ll fix this soon as we can. We’ll post back here when it ships.

Thanks!


#5

Awesome, thanks!