3D Particle System

[New version available]

Hi devformum!

Since today my 3D Particle system has been released,
You can use it by installing my ParticlePlugin - Roblox Plugin.

Currently there’s is no documentation yet and im still working on it. But i just wanted to release it asap.

In this place you can see the particle system in action.

and Here are some showcases of the possibilities:

To make a particle system simply install the plugin and open it in your game.
Select a basepart or attachment and click the “Create” button.

If you look into the objects Attributes you should find some parameters.
These controll the system, you can temper with them to make the system behave differently.

There are also some functions like:
DieOnCollision,
Use_CollisionEvents

Die On Collision is pretty explainatory

Use_CollisionEvents Howerver. If you check this box the particles will have a collision events. wich will be fired when the particle collides with something other then a particle or emmiter.

Cull_System will deactivate the particle spawn when you are away for an x amount of studs.

The systems are all automaticly initialized by the 2 scripts that the plugin adds. If you remove them you’ll have to make an alternative scipt for the systems to be visible in your game.

If you deside to use my system. Don’t be shy and show me what you’ve made. I’d love to see all your creations!

162 Likes

Hey there, awesome resource! I do have some minor feedback.

  1. Could you replace spawn with task.spawn since task.spawn is newer?
    image

  2. Could you also upload the source code to github so people can view the source code without having to install the plugin?

7 Likes

1: good idea i had no clue it existed,
2: i already placed it into a model, modulepack in my profile.

5 Likes

Looks brilliant!
Does this work with ParticleEmitter:Emit(Num)?

5 Likes

I was not fimilliar with that function until now, thxn for learning me something new.
For now thats not a feature yet but i will try to implement it.

2 Likes

Function added!

when you activate a particle system a set of functions returns. store this in a variable. then write variable.Emit(amountperstud)

This wil set the rate of the particles to the size times “amountperstud” it will also bind an event to it so resizing the part will call the function again.

local Module = require(game.ReplicatedStorage.ModulePack)
local ParticleSystem = Module.ParticleSystem

local system = ParticleSystem.ActivateParticleSystem(script.Parent)

system.Emit(.1)

emits .1 particle per stud of the total size. taking the x * y * z size

In order to recieve the update you have to close and reopen your place.

5 Likes

Wow! This looks so amazaing! I think it’s as good as the unity’s particle system!

4 Likes

Looks absolutely amazing, great work man,
I’ll sure keep this in my arsenal of modules much appreciated.

3 Likes

For some reason whenever I try clicking any of the UI it doesn’t work
Does anyone know what’s causing this?

2 Likes

Try restarting roblox studio or reinstalling the plugin.

3 Likes

yeah restarting should help. the plugin uses a module wich is not loaded due to roblox protecting you from script injection at first install.

3 Likes

Seems like I’m having the same issues. Even after reinstalling many times it’s still throwing plugin errors and the module still doesn’t load into replicatedstorage.

Error:


After doing some digging work I think I’ve found the issue.
One of the modules is erroring and preventing the script that requires these modules from running.
I’ve placed a comment suggesting what you might’ve meant.

3 Likes

Ah yes! i forgot to remove that. i will do it right away.

issue should be resolved now.

2 Likes

this is awesome! however, after ~3 minutes in the testing place, FPS will drop down by a lot

2 Likes

yep, i cant change much about that unfortunatly.

my guess is roblox is throttling the place because it has many loops. wich fire each frame.

And since you could crash someone’s pc with it. roblox resorts to throttling the place. but in this case its not to attack your pc. it just to calculate some nice particles. only roblox doesnt know that.

2 Likes

There are still issues with loading the ModulePack into ReplicatedStorage.
I’ve looked into it and what I found is that you can’t load models that aren’t owned by the place owner.
This ofc is an issue unique to plugins, I think Roblox implemented this update to prevent plugins from injecting stuff into your games?

Anyways to fix it I had to first go claim the model from the website and manually add it into ReplicatedStorage.

ModulePack Public - Roblox

I suggest the ModulePack be kept inside the plugin folder and parented to ReplicatedStorage on demand, instead of inserting.


Another issue was even after manually placing the ModulePack inside ReplicatedStorage, the plugin still loaded and ran before ModulePack loads in ReplicatedStorage.
So a WaitForChild should defeat this issue.

For some reason the particles are not working.
(i put the modulepack on replicated storage, reset roblox studio and reinstalling the plugin)

i just released an update again. it should be working now.

EDIT: to see the particles you have to be in play mode.

3 Likes

Very unfortunate to see that the plugin does not function… at all. Keep getting the same errors of modules missing etc. And then after reinstalling and the Gui loading it doesn’t do anything when you click on one of the buttons and just gives the same error.

and now i found the actual problem. i was refering to the module within the plugin script from within the ui script. only the ui script is moved by the plugin scrip wich means the path is inacurate as soon as its moved. this problem has now been solved so the plugin should work as intended now.

please let me know if this is not the case.

EDIT: i added a version number on the title of the widget. current version should be version(1.01)

1 Like