Adornee works on only a specific part while updating (I am new to posting)

I have an extremely fustrating problem that I am still on. I have recently started using Guis and I have run into a problem while using billboard guis specifically, everything else works fine but it is just the billboards that are killing me. I have probably skimmed through 10 posts looking for a solution including posts on other websites and none of them have worked. :weary:

This is the code, and I am debugging this with the print.


function Inventory:UpdateCollectGui(target)
	local collectGui = self.InventoryGUI.CollectGui
	
	local infoHolder = collectGui.InfoHolderFrame
	infoHolder.Description.Text = self.ItemData[target.Name].Description
	infoHolder.ObjectName.Text = self.ItemData[target.Name].Name
	infoHolder.Weight.Text = self.ItemData[target.Name].Weight.. " lbs"
	
	collectGui.Adornee = target
	collectGui.Enabled = true
	
	print(collectGui.Adornee)
end

It is printing out the “Adornee” whilst also not having the adornee property changed.

Here is an example,

As you can see the billboard is only showing for the red part.

Any help is appreciated!

P.S. I AM LOSING MY GOD DAMN SANITY HELP PLEASE

thanks

the code looks fine to me
did you maybe not orient the part the same? like, maybe the Top of all the other 3 parts is facing downards, so the gui is appearing underground

1 Like

I will go see if thats the problem thanks!

Edit: It seems that was not the problem I am beginning to think it is a roblox bug of some sort?

You could try manually changing the adornee to see if it works

1 Like

Changing it manually though a different script works but not the script i am currently using. aaa

I found the ISSUE!!! Thanks for your feedback!

1 Like

I have somehow broke the code again???

EDIT NEVERMIND

EDIT IT FEELS SO GOOD TO HAVE THIS PROBLEM SOLVED

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.