Allow walking animation to play with gun animation?

I have an idle animation for a gun, and while it works, it overrides the walking animation. I tried setting the priority to something else, but it didn’t work. Script if it helps:

		local animator ="Animator")
		animator.Parent = character.Humanoid
		local gunMotor ="Motor6D")
		gunMotor.Part0 = character.UpperTorso
		gunMotor.Name = "Main"
		gunMotor.Parent = character.UpperTorso
remoteevents.EquipGun.OnServerEvent:Connect(function(player, gun)
	if not player.Character then return end
	if not player.gunFolders:FindFirstChild(gun.Name) then return end
	local gunSettings = require(gun.settings)
	local character = player.Character
	local animator = character.Humanoid.Animator
	local gun = gun:Clone()
	local gunMotor = character.UpperTorso:FindFirstChild("Main")
	gunMotor.Part1 = gun.Main
	gun.Parent = character
	local animation = animator:LoadAnimation(gunSettings.animations.server.idle)
	animation.Priority = Enum.AnimationPriority.Movement
1 Like

Pretty sure the walking animation’s priority is Core (the lowest priority), so you should consider either changing the weight/value of the default waking animation via the animate script, or set your animation priority lower. Have you tried this?

1 Like