Animating with a tool problem

Hey

So i have this problem, and i’ve been trying to find a fix for days.
I simply want to animate whilst holding a tool.
For some reason it only works with this sword i made a while ago, but i need it to work with a different tool. But it just wont work. Watch video below.

With the sword that does work. There isn’t any welding what so ever. Just a tool and a handle.
Only thing different is that the wooden sword has more parts.
Look picture below.

Capture

I’ve tried motor6d, welding. Tried only using the handle. Anything i could find here or somewhere else.
Just wont work.

There is no scripts or anything. Just want to animate.

Any idea how i can fix this?

Thank you

1 Like

ok, so

So what i did, was import my blender mesh as 1 mesh and no textures and used easy weld.
That seems to work.
Just to animate it doesn’t matter that it aint have a texture

You solved your own problem and marked you as solution lol

He’s just telling others what he did to aid people with the same problem.