Animation is different when played in-game

Hi, I am trying to play an animation, but when it is played in-game, it looks different from the preview.

Expected Pose:

Pose In-Game:
Any help on this?
local rp = game:GetService(“ReplicatedStorage”)
local Pose = rp:WaitForChild(“HumanoidRemotes”):WaitForChild(“Pose”)
local humanoid = script.Parent:WaitForChild(“Humanoid”)

local JotaroPose = humanoid:LoadAnimation(script:WaitForChild(“JotaroPose”))
local JotaroPoseStart = humanoid:LoadAnimation(script:WaitForChild(“JotaroPoseStart”))

1 Like

I think that’s just what roblox does because the same happens to me so.

It looks like the character’s trying to walk and do the animation at the same time. The solution is to use a higher priority (right now it’s probably “Core”, the lowest).

Click on the image to visit the DevHub article:


You might want to set it to Idle, Movement, or Action, whatever fits best for you.


It still doesn’t work even at action

Judging by the way the character is posed in the animation editor and how they look in-game, I’m going on a limb and assuming that you don’t have any keyframes for the legs. If you do not have at least one initial keyframe for the leg or you’ve left them out of the animation, the legs will tilt with the Humanoid.

You can fix this simply by clicking the legs in the animation and then clicking on one of the movement handles. Don’t actually move any part, just quickly click on a handle to create a keyframe for the leg. This’ll “freeze” it in place so you can get the results you want.

1 Like

I have already made keyframes for the legs, and it’s still the same

I am late to the party but have you found the solution?