Animation scripts are broken? please help i_i

all the mobs in my game are animated via a local script and it always worked fine, until at one point today I came in Roblox studio and saw that the mobs were not animated! I started restoring old versions of the game in a panic, because I thought I had ruined everything, but even yesterday’s version of the game was broken. yesterday we played on the stream and all the animations worked perfectly. I don’t understand what’s going on. a roblox bug or I don’t understand what else could be wrong. the local script for animation has always been like this:

local function animateMob(mob)
	local humanoid = mob:WaitForChild("Humanoid")
	local animFolder = mob:WaitForChild("Animations")
	if mob and animFolder then
		local runAnim = animFolder:WaitForChild("RunAnim")
		if runAnim then
			local animator = humanoid:FindFirstChild("Animator")
			local walkTrack = animator:LoadAnimation(runAnim)
			walkTrack:AdjustSpeed(humanoid.WalkSpeed / 10) -- Adjust speed based on walkspeed
		warn("No humanoid/animation folder for", mob.Name)


and it has always been in startergui.
I also tried the standard server version of the animation with the same id of the running animation as in the local version and everything seems to work. id of the running animation:

please help me with animating mobs

first move to #help-and-feedback:scripting-support

1 Like

i dont need a scripting support here. i already posted the same topic in the scripting support where i really need to know what is wrong with the script if so. i have the whole script i posted in this thread. in this thread i need help about possible solutions and maybe it is really new bug.

moving to starterplayerscripts did not give a result