Animation Still Not Playing

Animation is still not playing, not sure what i’m doing wrong.

Screenshots : script:Screen Shot 2021-06-19 at 3.33.38 PM
in game:


properties: Screen Shot 2021-06-19 at 3.34.02 PM

I have tried moving the model to my group, anchoring, unanchoring, changing animation priority.

I’m not sure if this has to do anything with datastore since it is a tycoon.
Game link if needed:Office Tycoon! - Roblox

Any sort of help would help me tons, thanks.

1 Like

Are the NPCs rigged with Motor6ds?

1 Like

This is my first time using animation, I hired somebody to do it, how would I check this?

1 Like

Check the NPC’s torso. It should include all of the Motor6ds for the joints. There is also a Motor6d in the HumanoidRootPart:
Screen Shot 2021-06-19 at 3.49.21 PM

Check your output as well (View > Output)

1 Like

Do you have the animation Id? Is the script enabled? And where is the script located?

1 Like

Yeah I have it, the script is enabled, the script is located in the dummy.

1 Like

NPC torso:Screen Shot 2021-06-19 at 3.51.19 PM output:

1 Like

Has the animation been placed under the humanoid?
image
Try the script directly parented to the dummy.

1 Like

It seems it is, is this the problem? How do I move it up if it is: Screen Shot 2021-06-19 at 3.55.44 PM

1 Like

Check the properties of the animation, do you have the Id of the animation you want to play?

image

1 Like

Yeah, right here:Screen Shot 2021-06-19 at 4.01.10 PM

1 Like

I’ve also tried it in a test game, where it worked i’m just confused.

Try placing all the animators (the blue squares) underneath the humanoid if you didn’t do that before.

Please be noted that Humanoid:LoadAnimation() is deprecated. Instead, use Animator:LoadAnimation(), where Animator is a child of the Humanoid.

Doesn’t work, am I doing it wrong? Again, im sorry as I know nothing about scripting animations:

I’m sorry, but if you’re just gonna copy what I’ve said, it’s not gonna solve your problem. I’m not gonna give you the straight answer because I already state the Animator is a child of the Humanoid.

I understand that, my bad. So I have to replace Humanoid with Animator im guessing.

50% correct, I said there is a child named Animator inside of the Humanoid.

What he’s trying to say is that you need to reference the animator first:

local Animator = humanoid:WaitForChild("Animator") -- name of animator goes in here

This is it right? Screen Shot 2021-06-19 at 4.30.08 PM