So recently I’ve been reading through other developers’ scripts and noticed some, for example when using
GetService, assign multiple in one line.
local Players, RunService, ServerStorage = game:GetService("Players"), game:GetService("RunService"), game:GetService("ServerStorage");
local Players = game:GetService("Players")
Are there any differences in performance? Which is better practice?
Thats probably the smallest time save if any. Itll save lines tho ig
No idea. You can do a performance test and just hope that there’s no noise or differences to see which is better.
Any performance difference is going to be negligible.
Same thing when compiled. Just use what one fits best.