BillboardGUIs with LightingInfluence=0 are still influenced by lighting

BillboardGUIs with LightingInfluence=0 are still influenced by lighting. This is especially noticable with high exposure compensation. Some notes

  • Only occurs when AlwaysOnTop is false
  • Toggling between AlwaysOnTop true/false changes effects
  • This breaks bubble chat
  • Bloom especially seems to still affect it, among other things

Reproduction steps

  1. Insert billboard GUI
  2. Set AlwaysOnTop = false
  3. Set LIghtingInfluence to 0
  4. Set ExposureCompensation to 2 (easier to see changes)
  5. Toggle AlwaysOnTop on and off
  6. Expected result:: No lighting change
  7. Actual result: Lighting change

Additioanlly you can do this

  1. Up/down ExposureCompensation
  2. Expected result: No change
  3. Actual result: Visual change

This is especially annoying because it breaks chat bubbles, a default Roblox feature, among other things.

This bug has been around for a while. Like at least 2 years.

11 Likes

is the lighting too high? Or is it just something contained in your workspace?

Maybe I’m misunderstanding you, but I don’t think this matters. LightInfluence=0 means that the billboard GUI should not be influenced by light. Lighting setting shouldn’t/don’t matter.

The fact that it is is breaking bubble chat—and everyone else’s billboard guis, is the issue.

@Quenty i’ve never seen ANYTHING like this. Especially the fact that it is breaking things is certainly a huge problem. Have you tried searching the properties of the things that are breaking?

Ahhh. If you read the post above, you see I mention several ways to achieve this bug.

  1. Mess with exposure compensation (set it to 2)
  2. Increase bloom and render a white billboard GUI like chat bubbles

All of the information needed to reproduce the bug should be in the post. :stuck_out_tongue:

Does this happen only in Studio?

Oh whoops. I thought I filed this in engine bugs.

Guess my default tends towards studio. I’ll try to move this post.