Blender rig exporter/animation importer


The amount of frames (excluding one boundary frame) divided by the frame rate is the time it takes in seconds (all configurable in the render properties panel). I don’t think there’s a time limit of animations.


Boundary frame?


He means subtract one, to account for the fact that 2 frames are required for the first interval, and each frame adds one thereafter.


I can’t get this working with current Mixamo. I build the rig, export as fbx, and when I upload to Mixamo, it just appears as a solid mesh that doesn’t move.


Unfortunately, uploading a roblox rig with the mesh has never worked AFAIK. You need to export from Blender with only “Armature” selected, to get just a rig. The FBX will be about 24k. You’ll know it worked if, upon upload, you see a blue stick figure (the rig) doing a side to side looking idle animation. If the stick figure is immobile, or the upload hangs, something still isn’t right. Previewing animations is all stick man, so you don’t really know what you’ve got until the resulting Mixamo FBX is back in Blender.


Okay, it works that far. Then when I upload it to the rig in blender, first I get the error that there is no ‘active keying set’. So, upon adding one of those, I try again. And this happens:

No keyframes, and the skeleton is all over the place.


So, you saw your uploaded rig animating correctly on the Mixamo site? There are two ways to bring apply the resulting downloaded fbx to your rig in Blender, “Import FBX” being the go-to one, where you just choose the downloaded file (after setting Keying Set to “LocRot”, as you’ve found already discovered). Normally, this results in seeing the imported animation on its final frame.

You can also use Blender’s built-in FBX import to import the file, which will make a second rig in your workspace. That can be applied to the roblox imported rig with the Map Keyframes by bone name option, but it’s also useful just to import it this way to sanity check that it has the keyframe data you’re expecting. And you can watch just the armature animate.


Does this work with Blender 2.79, which was just released recently?


Everything goes perfectly well until I get to the part of seeing if the animation actually worked once back in blender.

My current issue is that the torso, such as the lower torso, isn’t really moving like it should.

Does anyone know how to fix this?*


Are you using the latest script? It’s supposed to auto-apply armature object transforms now.

What are your favorite Roblox developer resources?

Yeah, that seemed to be the issue.



how would I go about fixing this for a custom rig?


Simply make sure C0 and C1’s rotation matrices are the identity ones, not rotated in any way.


I’m having an issue where my armature does not move the meshes. This happens because I have added a tool to my character’s right hand (Motor6D from tool->hand, but have also tried the other way). Once I remove the tool, the posing works correctly again. As far as I can see the rotation for both C0 and C1 in the tool-motor are both (0,0,0).

Does anyone know why this happens, or what I can do to fix it? I would love to be able to animate with the tool (sword) in the hand of the character so I can get the movement right. :-C

EDIT: Figured out a solution for my issue. I simply converted the sword to an Accessory for the RightGripAttachment, and called Humanoid:AddAccessory().

EDIT 2: I have animated my model, but when I’m exporting the animation and pasting from clipboard, I get an arithmetic error in the plugin. It is hard to read, and nothing useful prints in output. Any clue? O.o


Try using “load large animation” instead (which you probably don’t currently?).


I tried that last night, but couldn’t get it working. Tried again today, and it worked. Awesome, thank you!


Reading through all of these replies regarding the new Mixamo situation, and I’m quite lost. Anyone willing to make a video tutorial or able to just explain it all? It would be greatly appreciated! I was able to get it to work before but that was only by following a tutorial. :sweat_smile:


It should work just fine with the newest addon/plugin versions, the addon its import fbx button now automatically adjusts the animation data to ensure it maps the animation properly.


Ah, I see now. I’ve gotten everything to work so far, but when I import an animation into blender it seems like my animation is being centered around the torso so all of the limbs are moving as the torso does. I’m not familiar with blender, but do you have any clue what I’m doing wrong?


It sounds like you are not using the latest version of the addon. If you see a “Apply armature transform” button in Blender, you use the latest version as of now.