Bot's not working after going from replicated storage to workspace

So I have a bot in my game at is in Replicated Storage. There is also a timer at is visible to the player via UI at all works. When I take the bot from Replicated Storage to workspace non of the bots scripts work. I’ve tried having it in workspace at first and everything worked so does anyone know what’s happening?

Im assuming they get moved by a script.

So first, disable all the scripts in the bots.

Next, in your script that moves them to workspace, enable all their scripts again.

If they get moved back and forth, remember to disable them again in the script after they’ve been parented to ReplicatedStorage.

1 Like

Are you moving the bot to the workspace in a LocalScript? If the bot runs on normal server scripts, they won’t run when you clone from the client.

It’s a local script in Starter Gui

Did not work. I don’t know what caused this

If you’re trying to run any scripts or localscripts in replicatedstorage, it wouldn’t work.

The script is in StarterGui. I’m getting a charecter from Replicated Storage to Workspace

You’re trying to reparent right?

A LocalScript will never work in workspace. Here are all the compatible parents of a LocalScript:

1 Like

Yes. Trying to get the bot from Replicated Storage to Workspace and it can do that but it disables all the scripts

Okay I’m back to assist on this, I got lost at first but let’s get back on track.

  1. Send us images of the bot’s children
    (Expand the bot Model and send a screenshot)

  2. Send us the script you’re using to reparent it
    (or the section of it that reparents the bot, whichever you’re comfortable with.)

Example of expanded Screenshot:
image

And a final question:

  • Is the Script that is reparenting the Bot a LocalScript?
1 Like

Bot:
image

Script:

And yes it is a local script

thats replicatedfirst not replicatedstorage…?

Yes but when I wrote this post at first it was replicated storage before I tried diffrent ideas

I notice you solved this, I’m sorry I didn’t get back to you; work and school are a tough balance and I was falling asleep nearly immediately after I got home. I assume you figured out that it needs to be an actual script (not local) that does the reparenting?

Cheers, and apologies for my untimely responsiveness.