Cannot Disable Roblox Player Movement

I’m having an issue where roblox is currently overriding my player movement system, but I cannot find a way to consistently disable roblox’s movement system.

local PlayerModule = require(game.Players.LocalPlayer.PlayerScripts:WaitForChild("PlayerModule"))
local Controls = PlayerModule:GetControls()

local ContextActionService = game:GetService("ContextActionService")
local FREEZE_ACTION = "freezeMovement"

    function() return Enum.ContextActionResult.Sink end,

Both Controls:Disable() and ContextAction do not work when actually playing the game, but both work in Studio and Client and Server simulation. I’m kinda scratching my head at this one.

1 Like

@SuperRyan456 I honestly I the player disable jump, any sprint/run scripts, and any movement scripts. Set their “WalkSpeed” to 0, disable jump by “UseJumpPower”. Sadly, this does still leave to spin but works. To disable toolbar, insert a local script into a backpack disabling it and add another one to re-able it.