Cannot upload MeshPart!

For a few days I’m attempting to upload a few meshes using a MeshPart but I get this error:


I also get this error in the output:


I’ve tried reinstalling studio, switching accounts, disabling my firewall, uploading a different mesh with less triangles. Nothing worked. Any help / solution is appreciated.

I can’t help you but I think this is a Studio bug or something or probably the site couldn’t connect with the studio because in the error it says HttpError , idk I’m a beginner :))

Usually, when this happens to me, it is because I am using a template that I already saved. To fix this, I will open a new baseplate to upload my meshes. Judging from the description above, it looks like you might have already tried this. I’m not fully sure how to fix this. I would try getting support from a Roblox employee.

1 Like
  1. Check your not on a VPN
  2. Try and upload as a fbx instead
  3. Restart your computer.

The Roblox servers can’t connect with your computer. Your WIFI might be blocking this, so try and check your ISP settings if none of the above works.


This happened to me while uploading a decal. Which is why I was surprised when I saw the decal in my inventory despite it giving me that same error. Try checking your Meshes inventory

probs studio error. try adding a meshpart to workspace, go inside it properties, hit the little file/folder button, and choose your meshpart.