Can't hold tool with a custom character

I’m trying to get the character to hold the tool. I can add it to my inventory but I can’t hold it and it just gets stuck in the ground. I have tried searching for solutions and this is the furthest i’ve gotten. I have tried anchoring and unanchoring the handle and the weapon model,I have tried rotating the hands so it faces the correct direction, and I have tried renaming the body parts to LeftArm, LeftLeg , etc instead of my own names yet nothing worked. Also he tool can be picked up by regular avatars just not my custom character, any fixes ?
weaponstuff


1 Like

You can weld it to the arm instead of using the handle.

You’ll have to animate the arm and weld the handle to it manually when the gun is held.

Did you place matching attachments inside the custom character? If you can, show a pick of the hierarchy of the custom character.

here’s everything inside
image

How can I do that ? I don’t really know much about welds

There has to be attachments in the hand or anywhere you want to have tools attach.uploaddelete me

Like this right? Doesn’t work
attachmentproperties
rightgripattachment
startercharactergrip

I believe that this post will help you figure it out.

1 Like

You have a WELD CONSTRAINT in the tool, not a weld. I believe this may be causing the tool to revert back to the place it was welded to. Welds look like this: delete me 2

1 Like