Cars not driving after pasted into game

  1. What do you want to achieve? My cars are not driving when put into the GUI. Basically I copy/pasted them from the studio session they were built in into the workspace of my game. My scripter attached them to work with the GUI.

  2. What is the issue? so this is NOT a scripting issue, the cars all work and drive. I tested them in a new studio session. The problem I am having is when I take them from the studio session they were built in and paste them into my game, they seem to get stuck in the ground or something. Its definitely an issue with taking them from the studio session they were built and tested in and putting them into my game, I did a copy/paste into the workspace.

  3. What solutions have you thought of so far? I have tried to move them up or down so the wheels dont get stuck on the ground but it seems to mess them up further

If I did a really bad job of explaining what my problem is I can link you to the game, you start with enough cash to buy a car and see the problem.

1 Like

Hey - This issue has happened to me a couple times as well. I have had a couple things that have helped me in fixing it.

  • First, try placing the car 1 stud in the air. That should most likely work.

  • Second, if that does not work, try replacing the chassis

  • Third, if that does not work, do a wheel swap.

Those are some of the things that have worked for me.
Best of luck,

  • Mboy00

so actually I looked into this a little bit. All of my cars were hovering above the baseplate in my game, some higher than others. If I wait a second before getting into the car they all work, I wonder if the higher I placed them above the baseplate the longer it takes for the driver seat to recognize the user.