Certain searches return "Catalog is temporarily unavailable"

When searching for “Easter Egg” in the library, the following error is shown:

However, searching “Egg” works perfectly fine

Is this a temporary outage or is it a bug?

21 Likes

Searching ‘easter egg’ with no caps seems to work?

1 Like

That’s so weird. “Easter Egg” still isn’t working. I wonder if any other search terms are broken

1 Like

Doesn’t seem to matter what I search it always comes up as “Catalog temporarily unavailable, please try again later.”

And to clarify this is only in the Library. Doesn’t seem to matter what category.

3 Likes

The entire library is offline for me too. Doesn’t matter if I’m searching for anything or not.

3 Likes

I’m pretty sure that what you search for is irrelevant, it just has a chance to throw up the message about the catalog being unavailable.

“Easter Egg” consistently fails for me, while “easter egg” works every time

I’ve had it on occasion where simply navigating to the catalog (as in featured) just throws up an unavailable listing for me but it doesn’t happen every time, the only consistent “unavailable” I get is when sorting by recently updated.

I guess it could be related to that catalog update they seemed to roll back?

For those that weren't around for it while it was briefly up


I have the same problem too. I had to go to spammed shirts to find the one I needed

Can confirm this is still a problem in the 2D clothing catalog. I can’t search “black cloak” but “black” or “cloak” on their own work just fine.

3 Likes

Same thing. I can’t believe roblox hasn’t fixed a bug from more than 4 years ago.

4 Likes

I’m pretty sure that these days, it’s just a case of sporadically occurring temporary outages. It’s really just up to luck for when and if this problem happens, if you wait about 5-10 minutes when you start getting this error it all starts working just fine.

A good analogy to this problem might be RNG in video games. Sometimes you get good RNG (catalog works fine, returns results) and sometimes you get not so good RNG (catalog temporarily unavailable).

As for the highly specific searches that consistently return this error even if the catalog servers are all fine and dandy, well we can’t really do much about that. ROBLOX probably is hiding things from us or something. I don’t really fully understand how it works right now, and I probably never will understand how the catalog works in this respect.

(I couldn’t think of a TL;DR, sorry)

I am having issues with the Catalog:

I was thinking it was my browser, so I tried a different one, but I ran into the same issues:

I can’t even access it on the app version of roblox:

So I have been having this happen for a few months, its started with me not able to press any of the items on the catalog, to me not able to view them. This is a big problem.

I hope this helped, and I hope I can get this fixed.

1 Like

UPDATE: I have found that it was my VPN. So if anyone is having this problem, and us a VPN, try turning it off.

2 Likes

This started happening again but in the library, only on the Audio page.
When I try to enter the Audio page, it shows “Library temporarily unavailable, please try again later.” and shows nothing.


Saw the console and it errored below message when I clicked audio page:

“Access to XMLHttpRequest at ‘https://www.roblox.com/request-error?id=6f93bf16-9fc4-4c7b-bacd-dc1543b1bf30&mode=&code=’ (redirected from ‘https://search.roblox.com/catalog/contents?CatalogContext=2&SortAggregation=5&LegendExpanded=true&Category=9’) from origin ‘https://www.roblox.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.”

11 Likes

This happens when I just try to press audio. Why does status say everything is working fine? Also, I got the same error as above.

I’m using Version 64.0 of Firefox, by the way

4 Likes

I am also experiencing this issue with the audio page in the creator marketplace. I noticed it started happening yesterday night. I see the same error messages as the 2 posts above me. I’m on the latest version of Chrome by the way.

3 Likes

I’m using Microsoft edge. I have the same messages as the four posts above me.Everything except audio is available.

Its fixed now. The library is back to normal

1 Like