Cloned parts can not use the "Resize" function

I am cloning a part and I have a tool that uses the resize function and its not working, could this be because the Clone function doesn’t allow basepart functions? This works perfectly with non cloned parts.

Snippet:
location.OnServerEvent:Connect(function(client,object,face,ndis)
local dtm = (mdis-pdis)*(scale)
local s = pcall(object:Resize(face,dtm))
end)

Is the clone parented to the workspace?

And please provide some code for us to examine.

Can u show the script, i really dont know what happend

cloned parts is just like any ordinary part, except its in nil
while in nil however, resize works perfectly fine, so there isnt enough context
does your resize function use the parameters: “normalid” and “delta”

You’re not cloning the part locally to be resized on the server, are you?

You might’ve lost track of the part, try doing

local s = workspace.YourPart

--your code here

s:Clone()
print('cloned') -- again, checking if it worked.
s.Size = Vector3.new(YourSize) 

print('resized') --checking if it worked

Also, please provide us your code so we can fix.

You can also do

local s = game.ReplicatedStorage.YourPart

--your code

s:Clone
print('cloned') --checking if it worked 1st
s.Parent = game.Workspace
print('parent is new.'..s.Parent) --checking if it worked 2nd
s.Size = Vector3.new(your size) --resizing
print('resized') --checking if it worked one last time

The clone is parented to workspace

I mean it’s literally a couple lines…
location.OnServerEvent:Connect(function(client,object,face,ndis)
local dtm = (mdis-pdis)*(scale)
local s = pcall(object:Resize(face,dtm))
end)

^

My resize function, to my knowledge uses all the required parameters.

My Resize and Clone functions are both being used on the server.

pcall is unnecessary here, and it also takes a function as input, so your code would throw an error. But, it shouldn’t cause the resize to fail. It would throw the error afterward, presumably.

location.OnServerEvent:Connect(function(client,object,face,ndis)
print("object: ", object);
print("face: ", face);
print("ndis: ", ndis);
print("mdis: ", mdis);
print("scale: ", scale);
local dtm = (mdis-pdis)*(scale)
local s = object:Resize(face, dtm)
end)

Can you replace your code with the above snippet and report what the print statements are saying?

Regular Part:
image
Clone Part:
image

Turns out that the problem was that the part was spawning a little bit under the ground when it was created. This didn’t allow the Resize function to work because it only works if there is nothing blocking it. It really should be a value to change that though…

I really appreciate all the help though :smiley:.

2 Likes