Collision bug / problem

Hello, Im having a problem with the collision for one of my models

So I made this bridge:

It was made in Blender, and once I imported it everything was okay, and I made all the surroundings etc.
Now, when I want to test it, I see that the collisions are not correct, that Im literally flying above the bridge

So collisions by default are in “default” which isnt really the best options for Blender or imported models, sometimes work, sometimes doesn’t, the best is using “PreciseConvexDecomposition” and It worked for me 100% of the times before, but in this case, it didn’t, it just doesn’t work

PreciseConvexDecomposition ON:

Please help me with this, re importing and placing the mesh again would be really laborious.
Any help and information is appreciated.


Its actually really serious


Hm, I’m not too sure about the issue but here’s something you could try to do instead of selecting all the meshes do it one by one and turn the PreciseConvexDecomposition off and then back on for each individual piece. Last time I did it to all the parts and it messed it up for me since I did it all at once, if that doesn’t work there’s a longer method you could take and that’s using invisible parts to go over the entire place but you’d have to turn collisions off for the entire mesh.


The first option didn’t work, I will take the second one, which probably will take a while but it will fix it at the end.
Thank you for your time