CSG Failures

No idea why but in the repro file I have attached, the union and negation will crash studio no matter what if you try and put them together. I’ve tried remaking the negated part and separating the large union and only trying to union part of it with that negated part at first and so far it has crashed studio every time without fail. It’s not a huge deal for me but I thought I’d leave it here in case there is something that can be done about it so it doesn’t happen in the future.

Union That Crashes Studio.rbxl (18.6 KB)


Studio Version:

Computer Specs:
Computer Specs.png

Got another one, same as DieSoft’s issue. While Unioning a series of planks into a deck I negated two additional Parts and tapered the front half of the deck section shown. When I tried to Union that with the two negated Parts shown in the images, the negated Parts turned solid.

I tried spinning the Parts 90 degrees and resizing them but they keep Unioning this way.
I then tried moving each .003 studs in the Z axis and then it worked properly.
Just thought I’d let you know it’s still not ‘perfect’ but it is getting better. Kudos to you guys.

Repro:CSG Error.rbxl (15.2 KB)

Looks normal enough, right?

Yeah, seems fine…



Guaranteed to lose a surface somewhere any way you cut it.

Block.rbxmx (218.2 KB)

1 Like

I’ve got a case of union a part with a negative part not actually doing anything. I’m trying to make the front of a train. I did manage to make it before but I need to move the lights so I’m trying to remake it.

csg_bug.rbxl (493.6 KB)

Do I put this here? I don’t know but I find CSG highly unstable. 99.9% of my unions become corrupted randomly and become unusable. I am considering just scrapping CSG due to how unstable it is (at least for me) I had this problem before but it’s never really gotten better. Some unions are perfectly fine but I think as these get more complex, they start going ?!?!?!

These looked something along the lines of the following diagrams

I’m really upset, I’m currently looking at most of my game invisible and I’m working on a strict deadline so it doesn’t help when this happens. This can’t be the same issue still of ‘pre-release CSG’ because CSG is out. Luckily, I saved copies in intervals of 30 mins so I could roll back and get at least one CSG back but now I’m going to change it for regular parts. I am not prepared to take the risk, I play it safe.

Attached is the place file with all 3 unions
CSG_Error.rbxl (16.8 KB)

1 Like

I’m unioning a special mesh that’s a sphere. When I union it it changes shape very subtly for no apparent reason.


The cause is because of the new CSG engine.

You can do this with literally any specialmesh sphere, too.

union error.rbxl (12.3 KB)

1 Like

This issue is related to the recent switch to a new CSG system, where the sphere primitive doesn’t exactly match the old one.

There’s always going to be a difference in what CSG outputs compared to the original primitives, but compared to what you’re reporting here, we’ve got a substantial improvement coming up.

Thanks for reporting

1 Like

Thanks and you’re welcome. I solved the issue shortly after.

Currently got an issue with a union that only won’t show in studio. I sent it to 2 friends and it works for them + it works in Roblox play mode, here is the error I get:

More info on my issue here but I thought i’d post it here too.

It shows on my spare laptop too which is on the same network as me. Seems to be a problem with just my pc. I did a full studio reinstall and disabled anti virus but nothing helped.

Hi. I made a complicated union that worked for a little while, then i used undo on something else later and it started having missing parts. Even a whole union is invisible.
brokencsg.rbxmx (119.8 KB)

I’m getting an error -21 whenever I try to union these two unions. I don’t know why. Help me please.
LighthouseBugLighthouseBugUnion.rbxm (2.8 KB)

Update: Now the union is invisible and has no triangles.

I will try to help you soon. I will edit this post with a possible answer in few hours.

Well, I can’t do anything with broken unions. Everytime something like this happens, you should hit Ctrl + Z until the union isn’t broken, fully separated (so all Unions/Negates are back to brick form), and then ask for help.
If you close your studio session, any broken Union will completely break without any hope to revert it.

Anything union’d with csgv2 cannot be exported with as a .obj file. You have to disable csgv2, separate the parts, and re-union-- which gets very frustrating.

1 Like

Was just given this error 5 minutes after a attempted union operation where I was attempting to create a rifle’s barrel. Here is the file.
Gun Barrel.rbxm (717.0 KB)

Another error if these negated parts are separated they just disappear and don’t return to be ordinary parts.
Odd Negated Parts.rbxm (16.5 KB)

I exported a car I made yesterday with CSG as a .obj fine and opened it in Blender.

1 Like

I believe I’ve found reason as to why CSG failures occur more frequently while further away from the origin.

In my current major project, Lands of Eyzira, the map is very large (4096x stud main gameplay area). Most of my building projects for the map at the moment are at the far reaches of the map (±2048 studs X or Z, Y is still ±50 studs to 0). A very common issue I run into is tools moving parts’ positions and rotations to values like 5.999 rather than 6. While I made a thread reporting this issue some time ago (which has now been updated), it got little attention due to it being passed off simply as nothing more than float error. This issue is notable on all tools. I noted that this has an extremely negative effect to unions, even if the error is <= 0.0009 repeating (aka it won’t display in the properties menu due to the three decimal place truncation) - This is what’s responsible for most of the issues stemming from building too far out from the origin, I believe.

I thought I’d put this here since it does have importance to CSG.

1 Like

I’m getting micro-displacement every time I union two blocks together.

Before CSG:

After CSG: