Default chat GUI not working when teleporting to game

There’s been a recent bug that I have no idea how to fix besides making a custom chat. I’m developing for this game that has a menu game before teleporting you to the main game. For some reason the menu game chat seems to work fine, but when ever I get teleported to the main game (using teleport service) the chat seems to bug out and not show up or work.

I’ve attempted to see if it had to do with SetCoreEnabled, but that wasn’t the case. I look up on the forum to see if something like this happened to anybody else but I came up empty handed.

At this point i’m thinking it might be an engine bug.

Have you tried just joining the Main Server place directly? It could be a problem with the code on that place.

Yea i’ve tried that already, it’s not only this game though, whenever I create a new game it also has the same bug.

Yeah this sounds like an engine bug then, I’ll run some tests myself to see if I can reproduce the results.

I have discovered the problem, when you have a local script that deletes stuff in the StarterPlayerScripts or StarterGui (usually when you are loading into the game) it will glitch the default chat.