Developer console not accessible anymore in games you do not have acces to

I was helping a developer find and patch a few bugs in a game i do not have acces to, i had experienced a bug so i wanted to get a screenshot of the error to show him, but the developer console did not show up.

The developer console does not show up anymore whenever i pressed f9 and when i checked the settings, the button was gone.

The help page is still showing the keybind though.

This is making it so much harder for developers to find bugs and patch them as other players experience bugs and issues more often than the developers themselves.

I don’t think dev console was ever given to players without edit access for a game.

It always were accessible, as this is the way i find out about bugs.

I always tell the players to press f9 and then to take a screenshot and send it over to me, so i know what went wrong.



You can say /console in the chat and it should work. But you only have access to the log and memory. Just saying.

(But no, you can’t get to it from settings anymore unless you have edit access)

Developers can turn off access to the console if they don’t want you to see it.

Read this thread: Hiding the Developer Console if it's opened - #5 by BenSBk

This might sound silly, but have you tried pressing Fn + F9 instead? Some devices already have shortcuts for that button.

1 Like

So i just got home and went onto my desktop, for some reason it is showing up on my desktop, but it was not showing up on my laptop.

I’ll come back with more info soon.

I can’t reproduce it myself. Please include more information regarding your system and perhaps even reproduction steps.

I have tried saying /console in the chat, it worked, but the button in the settings is just missing and pressing f9 does absolutely nothing on my laptop which has gotten an update today.

The update probably got corrupted somehow, but if thats the case, i think roblox should add more security against updates being corrupted whenever there is dataloss.

I have seen a lot of graphical issues for people who have gotten their updates corrupted not knowing how they can solve it.

Example of a serious issue:

I pretty sure that the button setting only showed up if you owned the place.

I have figured it out, apparantly some software decided to take over my f8 and f9 keys and they were completely remapped to a different key, so there was no f9 button on my keyboard.