Does anyone know how to fix this?

Does anyone know the fix to the hats not spawning in the character?

image

This is the wrong category to put this topic in.

But this depends on how good your internet connection is. If it’s good, then Roblox would be able to load every single assets in the game, otherwise you can try rejoining.

If that doesn’t help, check any malicious scripts within your game.

Sorry, and my internet is fine. It’s just the game.

Is this in Blender or Roblox Studio?

It is in the roblox studio obviously.

Is this issue sorted?
If not,
Are the hats in the same model as humanoid or different models?

If you are moving the humanoid, or it is not anchored, then there may be issues with the hat remaining in the same place as the humanoid moves, which could be fixed with a weld.

If there it is a hat directly from Roblox, I would make sure there is a “Hat Attachment” item under the “Handle”. If it’s a mesh you have imported, make sure it’s welded to the Humanoid.

Why? (The post above, why must you be off-topic?)

@envykillie Anyway, here’s a suggestion with this character importing.

Try using it on a random new baseplate, and after the character is loaded in, try pasting him onto the studio. I can’t much help unless you want me to try fixing this together. Mathew#3195

I think the issue is just part of Roblox’s bugs and such that the Staff hasn’t worked on possibly.
It’s the same outcome whenever you’re undo-ing an imported character and they literally dislocate all of their character’s accessories.

2 Likes

In team create, Avatar importing plugins may do this. You could instead play the game, copy your character model, and paste it in studio.

I’m Sorry Its my first time been Member and I wanted to have fun with posting first XD

Technically the DevForum is a kind of serious location, though it’s kind of awful there’s no topic location to talk freely on your choice and speak about things out of the topics selected out of them all

1 Like

Nope. They are normal and I tested a lot of people

I tried it on a baseplate it works. But, I want the character to be in the game because the owner wants himself in the game.

Does it work when you copy the character from baseplate imported and paste it into the studio inside of the team create?

No, it just switches to the hats falling apart.