Don't render decals/texture shadows if they are descendants of a basepart with CastShadow = false

#1

As a Roblox developer, it is currently impossible to disable shadows from decals and textures.

With the recent introduction of ShadowMap lighting I started tuning my game to support the new lighting in the best way, and the CastShadow property has been super helpful for that. But not being able to disable decal shadows has been a roadblock for me.

For example, I have a huge building that casts a big shadow on the majority of the interior. The roof is too high to inegrate lighting in a good way so I have always had GlobalShadows disabled inside this building.

Now I was able to enable GlobalLighting and disable the shadows from the roof and walls, but part of the glass roof uses a texture which casts a shadow that is impossible to get rid of without replacing the textures with something else:

2 Likes
#2

This is a bug, and it’s already listed on the recent Future is Bright phase 2 release thread:

2 Likes