Error appearing when starting game, not existing script

Im working on a game but i always get this error:
Model.MainModule:41: Expected ‘)’ (to close ‘(’ at line 3), got ‘end’ - Studio
The problem is that i cant click on it and there isnt any script connected to it.
My game also heavily lags when playing it.

Does anyone know what the issue is?

Maybe a virus? If it’s happening in every studio you open up then it’s a plugin you installed implementing a Model into the game with a Script. Try to find the plugin and uninstall it, then try to delete the Model or script.

I deleted all plugins that request script injection and its still there.
Can it also be the other plugins?
And yes, it happens in every studio.

Try disabling all plugins, since it could be any plugin, and then see if there is any difference

I disabled all and its still there :confused:
Are there any more things to check?

hmm can we see some screenshots and videos of the problem I don’t really understand what your talking about

I added a screenshot.
The error always pops up when starting a game in studio or in roblox.

Can you click on that error line to access the script? Or will it not let you?

It says “Source not available” when putting the mouse on it.

Can you delete the Model that it is inside of?

The problem is, that there is no model existing when searching in the explorer.

What I am guessing it to be is that it’s a plugin script however the Plugin has stopped being worked on therefore it doesn’t give the scripts and shows errors because the Plugin cannot work without it.

1 Like

Something like this.

Ok, thanks, but is it able to cause lag in the game?

If the script isn’t there at all then no, it should not. Just watch because we still haven’t solved the solution to what it is yet, however I can most certainly say if it isn’t there then you should be fine.

1 Like

Ok thanks for helping then, i will try to find the issue then if there is one.

I just checked it on another PC and the issue is still there, so it shouldnt be from a plugin, right?

After a few hours of work i found the “virus”. I actually have no idea what it is.
It was a few models that i made myself those gave the error, so i guess that a plugin may have damaged them. :confused:

1 Like