Error: "GetCore: GetBlockedUserIds has not been registered by the CoreScripts"

Reproduction Steps

I don’t know if anyone will be able to reproduce this, but my scenario is as follows:

  1. I have TeamCreate enabled for two players
  2. To be able to debug the game using Studio logged in a second player, I use a second Windows 10 in a VMware virtual machine
  3. Several times, when I go to Play (F5) the game in the virtual machine, Studio shows this error:

Expected Behavior

No errors while playing the game on the VM.

Actual Behavior

The error reported above occurs only on the virtual machine player and the 1st time I play the game in Studio on the VM.
If I stop the game and play again, the error does not occur.
But after some time, the problem repeats itself.

Issue Area: Studio
Issue Type: Other
Impact: Low
Frequency: Sometimes
Date First Experienced: 2022-06-16 00:06:00 (-03:00)


Is this error from your code, or from Roblox code?

You need to pcall and poll on GetCore because feature registration is not guaranteed before your code runs. Using a VM is likely altering the execution order of the script responsible for registering that feature, hence the error only on VM.

It’s a Roblox code (ChatMain), as shown in the image.

Theoretically, OS in a VM should have the same behavior as in a host. And especially the software installed on it. In fact, the 1st time and the only software I saw a different behavior was in Studio.

It looks like the code is already wrapped in pcall.

This has been happening to me for months, solo studio. Very annoying and weird considering it’s already wrapped in a pcall.

1 Like

Thank you for the report and repro. We will look into this.


Hey, the same error now is happening randomly in my official Studio installation (not only in my VM):

I have to stop and replay the game in Studio 2 or 3 times so that this error stops appearing and the game can start normally.

I’m already tired of it…
EVERY TIME I go to test the game, at least 1 or 2 times I get interrupted by this absurd error and I have to keep trying again until I get the game to start…
It has happened that I have tried MORE THAN 10 TIMES until the error disappears.
It looks like I’m trying to start an old engine…
And this problem has nothing to do with my installation of Studio since it occurs in the same way in 2 different installations (on the VM and on my PC - Host).
Could someone from Roblox pay some attention to this error?

GetCore API don’t always work. They should be wrapped in a pcall.

All pcallable API including all APIs which use HTTP in the backend can always fail and the game should function even if the API fails, at least to the extent possible. Proper error handling should always be done.

That is a Roblox script automatically inserted by the client in the absence of an override and is already wrapped in a pcall.

1 Like

“Magically” this problem stopped happening a few days ago…
Once again the Roblox team doesn’t give feedback on resolved bug reports.

I shipped a fix for this last week but forgot to follow up on the thread, sorry! Glad to hear you are no longer experiencing the issue though and thanks for your report.


This topic was automatically closed after 12 days. New replies are no longer allowed.