Exporting selection of a simple part spiked up my studio RAM to 1.4GB RAM, this had never happened to me before and it hanged/freezes my laptop

Hey, this issue happened around yesterday, while I was exporting a character model into an .obj file for external uses of other softwares, I encountered a weird issue that I thought it will happen. Basically, when I export the character model, my studio starts to hang and freezes my whole laptop without any obvious reasons. I cannot move my mouse nor interact my laptop, for a good amount of a few minutes before everything is back to normal and my model was exported normally.

Today, it happened again and I wanna investigate the issue. When I export just a simple part, like a normal cuboid from Roblox Studio, the issue happened as well. When I looked at my task manager whilst the issue was happening, I noticed my Studio took 2GB RAM, which is the cause of my laptop hanged/freezed from it. However, I cannot find what is causing the Studio to spike up to 2GB of my RAM, the total RAM I have in my laptop is only 4GB. Which leads 80%+ of my RAM being spiked up because of exporting a model from Roblox Studio. I tried exporting a basic part on another computer, it WORKS fine, no issues. I already tested this without any plugins enabled, but the issue still persist.

You need to upgrade your ram if your laptop allows for ram swapping or get a new machine. The minimum ram that you should have to comfortably use anything nowadays is 8GB.

Great. I can’t even buy a laptop because my parents don’t allow. Say, this problem didn’t occur to me before. Is there any way you can think of?

That is the only way unfortunately. Because of this beautiful thing called time as well as the updates that Roblox has been pushing lately, it’ll just start happening more and more. Might add up to other things soon as well. It is hard working with dated hardware but all I can really advise besides that is patience.

Great, I am going to quit my GFX career for a while. Thanks.

Why don’t your parents let you get a new computer? My phone had 4 gb ram lol

Parental controls… :roll_eyes:…

I don’t know, maybe try hard restarting your computer and saving your important files to a hard drive, hard resetting frees up some space in your computer, but the bad part is you loose all your files, many apps on your laptop take up ram, mostly hidden ones.

That worked, only once before it happened again.

The same thing happened to me at around the same time. I don’t think it is because of the amount of ram, as I have 16GB and I have never had any trouble doing anything on studio before. My computer did not freeze for quite as long, though. It was only about 5-10 seconds. This might just be a temporary issue with studio and seems to only be occurring for some computers, as you stated in your post. Hopefully things will return to normal soon.

Even the bugs report team doesn’t wanna investigate my issue.

Same thing! You’re not the only one experiencing this problem.
It’s really annoying, but instead of it going back to normal after a few minutes, it doesn’t do anything other than freeze and it makes me force restart my computer.

EDIT: I tried it on my other computer and it worked seamlessly (it’s actually more trash than the one I use rn). I have no idea what the problem is.

ANOTHER EDIT: The RAM in my desktop is 4GB. 440GB is the max amount of storage in my C: drive.

1 Like

HEY WAIT. Parental controls? your over 13…

Certain parents keep parental controls enabled for certain devices for kids up until they’re 18. It’s called being an overly protective parent. Questioning his age doesn’t help his issue lol

1 Like

Do you assume that teens which are over 13 years old are above are considered as adults?

Not sure if you found a solution but I’ve been encountering the same issue recently.

It only started to happen when I was adding tons of assets to my game and they were in Workspace. (By assets I mean things with different asset IDs, like textures/meshparts/decals/etc)

After putting these objects away in ServerStorage the issue went away and I can export things pretty fast without any freezing.

Hmm, sounds interesting. I must try that.

Our game has A LOT of things in Workspace, so this seems like it might work.

1 Like

Sounds weird but logical! I must’ve try that!

I found a fix that worked for me. In Beta Settings you have to disable Cage Mesh Deformer.

Not sure why it causes freezes for exporting selections, but when I disabled it, it works fine.



1 Like