Failing to import complicated mesh

I have made a complicated mesh in Blender to make my army’s officer program logo. However, when importing to Roblox, it turns out very wrong.

But when importing into Roblox Studios, this is how it looks like:

With an error:

I have went to that website and tried everything out, but does not fix the problem. Can anyone tell me why and the solution, thanks!


It might be this?

1 Like

Sadly, it does not work, it still gives me the error with a broken mesh. I tried other steps too.

If nothing works, I think the only option is to split up the meshes and parent them to the same model.

So here’s an update. The parts that aren’t showing up are actually showing up on the back… So, the parts you can see from the front view cannot be seen from the back view.

Oh. It’s face orientation. I believe Roblox incorporates backface culling, which basically means that if you are seeing the back of a part, it won’t be rendered. Check that the orientation of the faces is correct and all facing the same way.