[FIX] Playing Animations Troubles

Hello!

I’v some trouble playing animations humanoid ;

So i want play an animations on an humanoid, i’v already the animation with the ID, the only thing that don’t work is the script i used, it worked few days ago but it seem to don’t work anymore.

RobloxStudioBeta_2021-01-10_13-42-42
This is how the script look in the body.

RobloxStudioBeta_2021-01-10_13-42-52
So there is 3 things, as show in the previous screenshot : A script, basic settings (With scale and speed, that’s it) and the Idle Animation with the ID on it.
2021-01-10_13-52-36

The script (Made by Shea from RTWS) look like that :

local set = script.Settings
local sp = set.Speed
local enabled = set.Enabled
local hum = script.Parent:WaitForChild("Humanoid")
if hum then
	print("Success")
else
	print("No Humanoid")
end
local humanim = hum:LoadAnimation(script:FindFirstChildOfClass("Animation"))

--Playing Animation--
if enabled.Value == true then
	humanim:Play()
	humanim.Looped = true
	humanim:AdjustSpeed(sp.Value)
end 

And when i run it, there is absolutely no error.

I tried to re-upload the animations and i added the new ID on the IdleAnimation, but it still didn’t work.

I saw on YouTube someone explicating that if it’s a game for a group the animations have to be uploaded on the group, but the game is upload by my account, and the animations too.

And a lot of YouTube video upload their game before making the animations and play it on the humanoid, but me i didn’t, so i tried to upload it, and nothing happend, but if i had to upload the game before making the animation, why the animation worked few days ago? (Without uploading the game)

Thanks for reading, hope you could help me!

Have a good day.