[Fixed] Roblox keeps freezing when settings are opened, or chatting

Video of the issue

Video of the issue with the Microprofiler

I’ve been having this issue recently where my Roblox (Windows 11) starts up very buggy
Whenever I try to open settings, it freezes,
when I try to enter in chat, it freezes even worse

I have already tried
Updating my graphics drivers
Lowering my graphics in-game
Deleting the Roblox folder in Local and reinstalling a fresh version of Roblox
Running Roblox as administrator
Removing anti-virus

Has anyone else experienced this? Any advice?


I can’t see the video but this hasn’t happened to me, I’m thinking its just an system issue or something in the source code is malfunctioning.


The video is Private. You need to set it to Unlisted so we can view it.

What are your device specs?

1 Like

Fixed, You should be able to see the video now


Fixed. You should be able to see the video now

16gigs RAM
RTX 2060

It looks like your CPU is bottlenecking pretty heavily, according to the Performance Stats graph. This could be either the result of poorly optimized game scripts (such as ones that detect when the Esc key is pressed or a chat message is sent to run some code) or just bad hardware.

There’s a easy way to figure out what’s causing it though, with the Microprofiler. You can open it with Ctrl+F6. Then, click “Mode” at the top-left, and click “Detailed”. After that, record a video like in the main post of you clicking Esc and sending a chat message, and the problem with show up in the Microprofiler graph as really long, labelled bars.

Noted. I’ll post a new one later today doing that. Thanks.

New Video with Microprofiler

Here. Hopefully this can give a better explanation onto what’s going on

1 Like

There is a Pause button that allows you to easily inspect labels, by the way.

Regardless, I spotted a long label for GetCameraDevices, and it turns out this has already been reported as a bug. You should contribute to it with your recording:

Important to note that the staff are on holiday, and therefore can’t fix it until January.

On windows, click the Windows button (Or known as the start button) and type “Manage Camera’s”

When there, disable all of your camera’s.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.