[FIXED] Weird studio datastore issue happening very recently


The issue: Weird issue occurring with datastores in studio after I recently updated studio today. But, the issue isn’t there when I play the game through the website.

What I tried: I tried reinstalling studio and going on a 1 player test server, but the issue is still there. This just doesn’t make sense to me.

This bug is severe to my games development, as I’m completely unable to test features that I’m scripting.

(i tried using the console to try to edit datastores, that explains the red error. Also occurring to ProfileService (probably unrelated to this issue))


look up your issues before posting about them

1 Like

I already looked it up, but I couldn’t find a solution. I already updated studio and theres no more updates. I looked at those 2 exact threads before posting this thread.

1 Like

I tried to go on my game on studio on a different computer, and the issue is still there. This seems to be only happening after an update.

Edit: This seems to only happen to me, as I asked someone with studio access to join studio and playtest. Idk how to fix this issue

Edit 2: I reinstalled studio again and I’m starting to thing this is a studio bug. I commented out all the data code and tried making datastore entries and the error is still there.

Edit 3: I just restarted my PC and the issue is still there. Is this a studio bug?


This shouldn’t be posted here post it in bug reports. Or you could do platform usage support I am not sure if that would be the right place though.

1 Like

I’m uncertain that this could be a real bug, as this isn’t happening in other projects of mine. Should I post it there anyways?

I can’t post there anyways.

ya then do it in platform usage support I think would be the best as this doesn’t seem to be a scripting question.

Also I can’t even post anything in bug reports. Is there a reason why to it? Also I’m going to make a thread on platform usage support

ok. Bug reports you need a better trust level I believe in the devforum that way there isn’t false bug reports.

I do have the same issue. The only way for me to test DataStores is via published experience.

I updated the studio, and everything failed. So I tried restarting the studio, but still nothing. I uninstalled and installed it back, but nothing. I restarted my PC as well, which didn’t help either.

The only solution as of now is to make a debug variable to disable datastore access in your game so that you can playtest in studio (what im doing).