FreeCamera for taking in game recordings/screenshots


#62

I think this might be used as a cheating tool in some games, particularly ones that involves hiding.


#63

Would only be for the developer(s)… which isn’t really cheating :smiley:


#64

Oh, okay. :3

Also, I’m a fan of you!


#65

Welcome to the devforums, where everyone is secretly a fan of everyone.


(SOLVED) How do you make a click e to sit like in jailbreak?
#66

lol true


#67

Sorry for bumping this, but is this disabled now?

I can’t seem to activate it anymore.


#68

The key shortcut was too general and likely to cause collisions so it was changed. The FreeCamera is activated with Ctrl + Shift + P now.


#69

Still seem to be unable to activate it.


#70

I noticed that the free camera scripts are not always consistently inserted, a marketing contractor had problems recording in our event game half the time so I ended up just adding FreeCam to our codebase and adding it manually, which solved the issue.

@TheRings0fSaturn could you try starting a new server in your game a few times and testing each time whether it works? Please report whether it works sometimes or it if really doesn’t work 100% of the time.


#71

Appears to only load in sometimes. cc @TheGamer101


#72

Thank you whoever made that change! I couldn’t shift sprint and hit P in my game without the activation of the camera.


#73

I’m also having this exact problem. It’s driving me crazy - it was so good to make promotional videos with.

Edit: I think I figured out the why. If you have a character respawn using LoadCharacter(), it makes the FreeCamera consistently never work. I believe this used to not be the case a few updates back, but I could be mistaken.


#74

Ironically enough, my game uses LoadCharacter() so players can choose when to respawn.
Hopefully it’s fixed. :stuck_out_tongue:


#75

Make sure to file it as a bug report if you can isolate it on a baseplate (i.e. calling LoadCharacter on a baseplate causes FreeCam to break). They won’t fix issues that are not properly reported.


#76

Don’t mean to bump. But a group game of mine is experiencing a bug where certain group members (who do not have access to edit the games) have the ability to FreeCam. I’m wondering if anyone else has experienced this, or knows of some solution. Thanks.


#77

May be a good idea or opportunity to allow us to set our own keybinds?