( Game May Not Function As Intended ) problem

  1. What do you want to achieve? Take out that “This Game May Not Function As Intended”

  2. What is the issue? /\ /\ /\

  3. What solutions have you thought of so far? I have read some posts that have the same problem, but it’s still not working (Visiting it, Updating it, and stuff)

Maybe I have not looked enough, but I hope I did
I have tried to visit it, checked If it had filtering enabled in the workspace if it was somehow unchecked for some reason, and Updated the game, with noticeable changes… Now, what should I try?

Also, this is my first ever post so that's cool

3 Likes

Also, I apologize if i respond late lol.

The developer needs to update the game in this case. It most likely contains outdated scripts in it. Roblox releases new features and things change often. This just means the game needs to be updated. Update your game and try playing it.

Oh, okay. I’ll try Making my Scripts More “Updated” if i have the skills, haha

Try re publishing the game, that should solve the problem.

That’s not the issue. The issue is when the FilteredEnabled property in Workspace is disabled. (Disabling it doesn’t actually do anything other than display this warning.) Lots of people are having issues with the warning not going away, though, so it’s possible it’s just a Roblox bug at the moment that it displays. The actual game should play no differently, regardless.

6 Likes

Oh okay, So I just gotta wait then?

1 Like

Yes, just wait. Like @rogchamp, the game will function as intended. The message pops up as soon as your publish a game. That’s all you can do, there’s no speeding up the process.

If you’re lucky, you could get the message cleared today but if you’re unlucky, you may have to wait substantially longer. I personally publish a game as soon as I make it so that I don’t have this issue, however, I realize that this isn’t a solution for everyone as not all games are just showcases with no actual scripting involved.

Hope this helped! (´∀`)

7 Likes

If waiting isn’t working, it probably will but just incase someone else is reading this and they’d like to speed it up faster:

  • Play the game and make sure it’s set to Public.
  • Quit the game and open studio.
  • Republish your game.
  • Play it again and refresh the page.

It should be gone.

I have republished the game, it’s set to public, and I refreshed the page. So I think I’ll need to wait.

You need to go into Workspace’s properties and set FilteringEnabled to true, after this publish the game and the message should be gone

I have done that already,

So that doesn’t fix it.

Also, it’s still there so yeah (Update or idk)

Yay, now it’s gone finally. 12 days