Grapejuice - Easily run Roblox Studio on Linux

I’ve gone ahead and set up a Discord server for discussion. The link is in the original post.

Grapejuice now has a builtin updated so you don’t have to check the repository yourself for updates :slight_smile:

This looks really cool and I’m excited to see what will come of it, because I would like to switch to Linux, but it’s the lack of Roblox support which is stopping me, hopefully this will solve that issue. Great work!


I’ve been trying to get Grapejuice to work my Ubuntu Budgie install, but it just wont launch Studio. I can run Grapejuice and troubleshoot whatever I need to troubleshoot, but Studio wont open. Anything I’m doing wrong? Can someone possibly help me?

A change last Thursday causes new installations of Roblox Studio to fail, we’re currently trying to understand why. When we know why, I’ll include a patch in Grapejuice. If you want to, you can join the Discord server to track progress and ask questions.

1 Like

Oh my, this is seriously the best thing i’ve seen in the resources on the roblox devfourms in a while!

I’ve always wanted to switch to Ubuntu Linux because of all the features you can possibly do with it, but i never used it seriously because of the fact i couldn’t use roblox studio on it. If this gets refined and still gets updates, i’ll happily use this and linux!

1 Like

Every time I try to run any of the python scripts I get this error:

I couldn’t take a screenshot in Lubuntu so that’s the best I could do

I followed the install guide and even reinstalled it myself but still no dice.

You’re supposed to use, as the instructions say. The file is only there for packaging.

1 Like

Edit: I didn’t mean to sound rude at all, rather I’m a bit disappointed that I couldn’t get it to work and I’m eager to try and get it working on my machine…

I tried that and still no dice, it seems to install dependencies then just, nothing. I cannot for the life of me figure out what’s going on (is it supposed to create a shortcut on the desktop by the way?) Whenever I run, it doesn’t goes any further than installing the dependencies :confused: or is it just that it doesn’t work on lxde?

It should just drop a shortcut in your applications menu. It’s under the development category.

Oh silly me… I genuinely thought it made a desktop icon :man_facepalming: but anyways I tried again (I had to git clone it again) and it worked. Thanks for the help :slight_smile:

Edit: You may add to the Readme that wine must be set to emulate (by Winetricks) a Windows 7 or greater installation. By defaults it tries to emulate WinXP (at least that’s what it has done on my install).

Edit2: welp nevermind, Studio outright crashes right at startup :frowning:

This is really useful, especially with cloud pcs which only run linux. thank you!

What distro is this?

Grapejuice runs on theoretically any distro with Python and Wine, and all of the dependencies. I think Brinker is on Arch or Manjaro, and I’m on Ubuntu. We have a few other distros as well in the discord.

1 Like

Grapejuice has been updated to version 1.7.8. It includes a fix for an issue that caused new installations to not work. So if you weren’t able to get Roblox Studio working previously, please try again :smiley:


Alrighty then, I’m currently giving it another go (I genuinely thought I messed something up last time I tried), fingers crossed! :crossed_fingers:

Edit: Alright that’s progress! It’s going so far so good (sorry about the annoying Moiré effect…)

Okay new problem so far: I get a OpenGL context creation error…?

I’m not sure why, but when I click Install Roblox, it doesn’t install. Not sure what I did wrong.

Figured it out, I forgot Wine.

I get an errormessage saying: “Roblox requires Microsoft Internet Explorer 6.0 or greater” when trying to install roblox. But it looks like IE6 is there. What could be the cause?

I updated the topic with a PSA. The issue presented is not easily fixable because the captcha popup uses the most unstable component of Wine. This is not a showstopper though.

PSA: Roblox has added a captcha popup to the Studio login screen, this makes it crash when it is run with Wine. If this happens to you, you can authenticate studio by editing one of your games from the website. You should only have to do this once.


I decided to set up an Ubuntu Budgie 19.04 install to try this out, and it works pretty well.

I did run into a problem initially where “Install Studio” would do nothing, but it ended up being I missed the step to install WINE. Probably should display an error that WINE isn’t installed like Lutris does? Another suggestion I have with the Roblox Studio executable is to add the “-ide” flag like in Windows with the desktop shortcut so the “Installing Studio…” window doesn’t always come up when launched.

Also did some testing with OpenGL, Vulkan, and DX11. Found the following:

  • OpenGL mostly works except for PluginGuis (already in the README)
  • Vulkan just crashes outright
  • DirectX 11 with DXVK works better than OpenGL for me because PluginGuis don’t have any problems. There is an odd case where creating a new one after starting studio like the Toolbox will cause performance to become terrible. If DXVK is not used, the performance is always terrible.