Group Linked Sources 'do not exist'?

Loading a Linked Source fails in group games - they seem to work inconsistently in studio, but never work in game.

I get the error:

Script “rbxgameasset://Scripts/name” failed to load in “path”. Script doesn’t exist.

To reproduce:

  • Edit a group game
  • Create a new Linked Source and a script in a ServerScriptService and get it to print someting
  • Save and play the game
  • Open the developer console and look in the server log

I’m having the same exact issue and I don’t know why.

1 Like

I’m having this same issue, I just didn’t realize it was because I was in a group project


I went crazy trying to find the issue, to find out it’s a ROBLOX bug.

1 Like

Yes, this needs to be fixed as soon as possible. Right now I’m just avoiding the problem and doing other things until this is fixed. I could see this majorly breaking group games that rely on linked sources.


Yeah, this is happening in my game too.


I was having this issue was well, and didn’t have time to deal with it so I just uploaded the assets as my own.


Still occurring with me too. It worked about 2 months ago, but I haven’t been able to get it to work since :frowning:

Yup, exactly the same for me and many other users I’ve talked to.

This needs to be fixed urgently


Has LinkedSource ever worked for groups?

IIRC that issue was in the web backend. Unfortunately because of the studio bug where we are not correctly creating some assets as group assets it is hard to verify the status of the web backend empirically.

So is there a possible fix that can come sometime? Because this actually DID work for at least a certain amount of time, because I have multiple LinkedSources that are being used in a Group Game right now that function. I just cannot create new ones.

1 Like

The studio team is investigating the regression, and hopefully will have a fix soon.


Still having this issue, and it’s effecting me dramatically. Any indication on when this bug may be fixed?


I just ran into this bug, after an infuriating couple hours I find that this (even more infuriatingly) is a bug that’s been around for months



During the second half of December we have a very limited release schedule in order to maximize the stability of the platform. My understanding is that work for this fix is mostly done, but we will not be able to enable it safely for everyone until early in the new year.


I believe this has been fixed as of 1/4. Can anyone confirm?

Very sorry for the delay. I blame… hm… Chris. Yes, I blame Chris.


JK CHRIS!! You the best!

1 Like

I’ll check it out in a moment :slight_smile: