Grouping Objects

I’m trying to “group” a bunch of objects together into a collapsible folder so that it’s easier to manage my workspace, but I’m unsure of how to do it correctly. If I make it all a single model, then I can’t edit the individual parts of it with any ease. But so far, that’s the only way I’ve found of grouping them.

Instead of grouping the objects, use folders. Add a folder to Workspace and name it whatever you want, then drag and drop the objects into the folder. You can still edit the objects when they’re in the folder, but it’s much more organized.


This works, but… seems to have broken one of my scripts, somehow?

maybe if its checking for a model only, or its checking for a certain name and you didnt name the folder correctly?

Well, it SEEMS to be looking for something in ‘Workspace’, so I guess I have to specify the folder it’s in.

local fallTrigger = game:GetService('Workspace').fallTrigger

is fallTrigger your folder’s name?

No, fallTrigger is an invisible object in the world that, when the player walks into it, makes them sit (so they can fall down a ramp I’ve got set up). For now, the folder’s just called “Folder” until I get it working.

I should note that I tested, and this script worked before I moved everything into the folder.

1 Like

hmmm. show me your hierarchy of workspace? because maybe the falltrigger is moved somewhere or something

You really should use models. Have you tried using image to select individual parts in a model?

Anyway, your problem is that your code is trying to reference an Instance that you’ve moved somewhere else. Update your code to reflect its new position in the hierarchy.

local fallTrigger = game:GetService('Workspace').Folder.fallTrigger
-- replace "Folder" with whatever you decided to name your folder

I do use models, it’s just in this scenario it really doesn’t make sense to.
Anyway, your solution works, so thanks!