How can i reword this?

I want to not use these “script.Parent.Parent” over and over is there any other way to make it look atleast i a little neater? heres an example of what it looks like


just use a variable for the script.Parent.Parent then:
local ui = YourVariable.Parent.ui

Well im trying to get rid of the triple or how ever many parents there are

it depends where it is. If the ui is inside the PlayerGui, you can reference the PlayerGui and the Gui instead of these annoying parents

We CAN reword this, but I would say this is the most efficient imo.