How do I make my custom AI not bounce a lot?

I’m unsure of where to put this, since it’s kinda a hybrid issue that deals with scripting and physics. I hope anyone who has experiences with making custom AIs that aren’t specific to R6/R15 can help me.

So this is my custom AI. He’s a bulky rock.

This is one of his attacks. A simple jump up into the air and using his derrière to crush his enemies.

Now, this is fine and all but well in the actual game, when he’s walking, he’s bobbing up and down a lot more than the animation playback, even phasing through the floor, and when he uses the jump attack, he just goes up and glitches through the ground.

I’ve made sure every part of him was massless, I adjusted the humanoid’s hip height, etc. Is there a way to disable animation physic interactions with code?

--- I don't need to give the entire code, but it's basically
--- 1. Go towards target


--- 2. Use attack if close enough

local Animation = Humanoid:LoadAnimation(Chosen)

I’d rather not anchor him when he does an attack, because I do have attacks where he also likes to move.