How Do I Prevent Humanoid From Sliding

  1. What do you want to achieve?
    So Humanoids Don’t Slide Under High Amount Of Speed So They Don’t Get Stuck To The Wall
  2. What is the issue?
    The Humanoids just slide under high speed when I use :MoveTo
  3. What solutions have you tried so far?
    I tried changing lookin it up on internet and making max slope angle 0

Maybe anchor the humanoid root part when the humanoid is moving to the new position

local Player = game.Players.LocalPlayer

local Char = Player.Character or Player.CharacterAdded:Wait()
Char.Archivable = true
Char:WaitForChild("HumanoidRootPart").Anchored = true

that could work let me try that

is still transfers a bit of momentum after its unanchored making it slide a bit but atleast its some progress thx

Unanchor the humanoid when its fully stationary

it just transfers the momentum even when its anchored for 1 second

i think i fixed it by making body velocity 0 when it reaches new node(let me try it again to see if its just luck or not)

You can set the humanoid walkspeed to 0 at the same time you unanchor the humanoid

1 Like

yeah

script.Parent.Nodes.Changed:Connect(function()

	script.Parent.Parent.HumanoidRootPart.Velocity = Vector3.new(0,0,0)
	
end)

made it work(since anchoring it still kept the velocity i just thought about clearing it)

1 Like

thx for help I wouldn’t be able to figure out how i could do it without ur help.

Np, anyways if your going to move a lot the humanoid here a little script

Humanoid:GetPropertyChangedSignal("MoveDirection"):Connect(function()
			
	if Humanoid.MoveDirection == Vector3.new(0, 0, 0) then
		print("Setting velocity to 0")
		game:GetService"RunService".Heartbeat:Wait()
		Humanoid.Parent.PrimaryPart.AssemblyLinearVelocity = Vector3.new()
	end
			
end)