How do I show the jump button while JumpPower is 0

As some of you guys know, when you set the JumpPower of the player’s humanoid to 0 on mobile, the button for jumping does not appear. While this can be handy in some cases, it can be less handy in others. Is there a way I could show the jump button while the JumpPower is still 0 on mobile?

1 Like

How about setting he jump power super low and then removing the jump animation? Or remove the jump function when it pops into starter player scripts or something.

1 Like

Yes. There is. You can try adding a UI instead If you want to keep your zero jump power. You can add a UI or button that is similar to Jump Button in Mobile that If they press, it will grant them jump power or you can use the .Jump property which is

game.Players.LocalPlayer.Character.Humanoid.Jump = true
1 Like
—Put a LocalScript into StarterGui and write this:
game.Players.LocalPlayer.Character.Humanoid.JumpPower = 0.01

Tell me if this works.

It’s something in roblox core scripts, so I’d suggest that for better reliability you code your own jump button! This will actually work with what you want, setting the jumppower to 0, not setting it to 0.000001

I’ve found if you turn UseJumpPower off and set JumpHeight to 0 it shows the jump button, then when you need to, just turn UseJumpPower on and then set JumpPower to the desired value!


good idea if it actually works, but is a hell of a thing to use two same systems at the same time, code your own button, it’ll be better