How do I stop these placeable blocks from phasing through each other?

--place block
local block = game.ServerStorage.stoneBlock:Clone()
block.Position = mousePos
block.Parent = game.Workspace.Map

This is honestly all the relevant code.
It works just fine, it’s just that, seeing as the brick is placed directly on my mouse position, you end up with clipping like this.
image
How can I prevent this, and only have them place on top of/next to each other/other map items?

Is the CanCollide property on the blocks enabled?

Yes.

character limitttttttttttttttttttt

There are lots of posts on “block placement systems”, try searching to see if there’s anything relevant